Very Slow Responses


I have just install DOpus 9 (been awhile since I have used DOpus), and I am having a couple of issues

  1. At times seems to take forever to enter a folder after double clicking (can take upto 5 seconds before anything happens

  2. Problems when attaching my MP3 Player (I use redchair software to connect) and this is incredibly slow to communicate, where in Windows Explorer it is very fast, this might be related to the first problem.

I dont know if anyone else has had this problem, but if not is there an override, so that when I need to do particular things I can use Windows Explorer over DOpus.



This FAQ may help with the slowness, depending on exactly what the problem is:
[Crash, exit or high CPU when viewing certain directories)

If you need to use Explorer it's still there, just run Explorer.exe from the Start Menu.

You can also make a button in Opus which launches Explorer showing the same folder as the Opus window:

Explorer /e, {sourcepath$}

Of course, you can also quickly disable Explorer Replacement mode via Preferences if you need to use Explorer a lot for a while for some reason. Opus will still be available, it just won't be launched when you double-click folders in other programs or on the Desktop.

Thanks for the reply, but doesn't seem to be relavant as it seeems to relate to DOpus crashes.

I have just tried installing xplorer2 lite and I have no problems like with DOpus.

I can understand to a certain extent why Network is slow to access (though it is slower than Windows Explorer or xplorer2), but what puzzles me is when accessing my MP3 Player through Creative Drivers or RedChair Drivers it is incredibly slow through DOPus, but not with any other Explorer Apps, this to me looks like a bug in DOpus



Update: I have found this article which mentions problems with BitDefender, but no solution posted, so not sure if anyone else has had performance problems with DOpus and BitDefender ... itdefender

The FAQ isn't just about crashes, it's about general problems with slow-downs, high CPU usage and also crashes. I don't know for sure if it will solve your problem but it might be worth a try.

Regarding BitDefender, can you disable it and see if the problem goes away? If it does maybe we can then work out how the other person fixed it (or email them to see if they can tell us).

I've been happily using DOpus 8 for the past eighteen months, on my Tosbiba laptop running XP SP2 (Home).

I regularly use two external USB 2 hard drives for storing backup images. There's never been a problem with DOpus 8 - I fire up the external drive, plug the USB cable into the laptop, click to display the Folder Tree, and my drive is recognized and available for file copying.

I'm having a problem with version 9 (now at

One external drive (80 GB Western Digital) works exactly as before.

The other (200 GB Seagate) is giving problems. After I plug the USB cable into the computer, Windows doesn't display the usual two dialogs (which I normally cancel). A new drive letter appears in the DOpus Folder Tree, but it doesn't show a drive name like it normally does. When I try to open folders in the external drive, DOpus shoots up to 99% CPU, I get an hourglass, and nothing else happens. I have to close DOpus to get control back.

Windows Explorer works normally with both drives.


What were the two dialogs that you used to normally cancel? Do you know why they no longer appear? Do they appear if you exit Opus and then insert the USB drive?

Be sure to exit Opus fully, via the taskbar icon's menu:

Thanks for your response,

I've spent quite some time today trying to figure this out. I found that I don't need to involve the external hard drives to run into the problem.

My system is set up with three partitions - C, E, F

I have toolbar buttons which I click to access these partitions - Go "E:" and so forth.

With the Folder Tree hidden, I can click these buttons freely and DOpus works fine with all three partitions.

With the Folder Tree displayed, the same buttons for C and E still work normally, but F gives trouble. I opened Task Manager before clicking F and watched - for the next sixty seconds or so, the CPU for DOpus ranged from 85-98%, and memory usage gradually climbed from 22 MB to over 30MB. It appeared to be in some sort of endless loop. I then terminated the DOpus processes.

FYI, I ran chkdsk with the /f switch on all three partitions, plus used the Seagate SEA Tools to check for bad sectors (a six hour test). Everything about the disc checked normal, DOpus still gives a problem.

I never had a problem with version 8.

Any insights will be appreciated.

Interesting. It may be something else in your folder tree, rather than anything to do with the drives themselves.

Is there anything "unusual" in your folder tree? (e.g. Devices or virtual folders that most people wouldn't have.)

Could you try changing the Start Folder Tree at... options as well as the Show in Folder Tree options, all in Prefs - Listers - Folder Tree to see if any of them make the problem go away? Hopefully that will pinpoint the cause and we can work from there.

I tried various combinations of display options - no luck.

By the way - with Task Manager open and DOpus doing its runaway CPU/memory thing, I exited the program using the method you suggested. DOpus disappeared from my screen, but dopus.exe and dopusrt.exe continued to run.

When the lister goes wrong, can you still open other listers and use them okay?

Did you try removing everything from the Show in Folder Tree options?

Could you try running Process Monitor in the background (set it to only show events for dopus.exe) and see if Opus is accessing any files or directories when it gets stuck in the loop.


Unchecking "ZIP files and other archives" in Folder Tree options appears to prevent the bad behavior.

To answer your question - yes, I can open and use other listers while the first one is going crazy, but 90+ percent of my CPU is still being tied up.

I'll see about setting Process Monitor up and will get back to you. Thanks again for helping me.

Maybe there's a particular zip file that is causing Opus to go wrong. If you can track down which one it is (probably one in F:\ ?) and send it to GPSoft then I'm sure they'll fix or workaround whatever the problem is.

Only one zip file in F:, so I moved it to E:\ and the problem followed it.

The zip file is 45 MB, with 43,750 files inside. It's been sitting in F:\ for a long time without problems, so I have to think that DOpus 9 is the culprit. Or, could one of Microsoft's monthly security updates have changed something in the equation?

I'll see if I can contact support via email - I don't want to create any confusion by using their online form.

Thanks again - and see you on the Donation Coder forum as well!


Opus 8 only displayed the ZIP file itself in the tree, but Opus 9 can expand the contents to show sub-folders, and to do this it needs to open and read the file. 45mb is reasonably large but not huge so I wouldn't have thought it would take this long to read the table of contents from it. What happens if you double-click the ZIP file to open it in a Lister? Maybe the file itself is corrupt in some way.

As long as the Folder Tree isn't showing, I can double click the zip file and it opens normally (I use WinZip).

Ok, but what I asked was, what happens if you display it in an Opus Lister. The fact that WinZip works isn't really very relevant :slight_smile:

I made Opus the default zip handler and double clicked the file - it displayed in the lister pretty quickly.