Very slow sFTP transferrates


i have a problem with the sftp-module for directory opus. Ive bought that module because i dont want to use filezilla or winscp anymore, but with the dopus module i get very slow transferrates.

Weve testet it with different servers and different internetproviders too. Weve tested it on vista 64bit and winxp 32bit. All the same problem. With filezilla we get 1.2mb/sec downloadrate and with winscp nearly the same. With Dopus we only get 190-500kb/s. We have tested all possible settings weve found to optimize the connenction of dopus without any result.

Thanks for help

What sort of speeds do you get with programs other than Filezilla?

At least with some sites people have reported that Filezilla is much faster than everything else, with everything else being about the same speed. Nobody seemed to know why last time I looked around the net for info on this; not even the author of Filezilla seemed to know why.

i used winscp and i get around 900-1000kb/s. that would be fine for me, as i can use 2 connections at the same time. but on dopus we mostly get aounr 300kbs, that not enough for me.


Thanks for checking.

The best thing you can do is contact GPSoftware via their support form and provide as much detail as you can about the server you are connecting to, any network stuff that might be a factor (e.g. slow network, server on the other side of the world etc.).

I've noticed this too, but the ftp part of DO is somewhat slow in general..
It seems to only process files one by one, instead of x files simultanously, which significantly reduces speed when downloading several files (especially when they're small).

I tend to only use DO to copy urls from the ftp locations, then let another tool in my toolbox do its magic (as in speed) with them, unless it is just a file or two.

Most FTP sites only allow one or two connections so automatic parallel FTP transfers often wouldn't improve things much, especially if you want to save one of the connections for browsing directories.

Of course it's up to the site administrator and some sites allow more than two connections, and even with two connections it can make a difference with small files, as you say. So it's not a bad thing to have (ignoring the increased complexity in terms of maintaining a queue of files to transfer, dealing with errors on either or both connections, and so on) but it won't give as good/automatic increases in performance as you can usually get with HTTP (where the per-user connection limit is usually higher than 2).

That's just my take on it. GPSoftware may feel differently.

(Of course, as well, there's nothing to stop you opening additional connections to the same site manually, apart from that it's a hassle, obviously.)

it seems that there is a limitation bug.

If i copy a file i not get over 199kb/s.

But if i copy 4 files at the same time everyfile gets up to 199kb/s so i get an overall download speed from ~800kb/s.

I Cant be a Serverprob because Winscp and Filzilla dont have that limitation. I tried t set fixe Downloadlimit in the dopus serverconfig, but no change.

I Cant be my Config or provider or hardware because a friend has exact the same problem and he has his home over 500km away.

greets Rafael

Are Winscp and Filezilla transferring more than one file at once?

It's normal/common to find that a single transfer cannot go as fast as multiple transfers in parallel, due to either server-side throttling or the way the transfer protocol does or doesn't deal with network latency. This is why some download managers let you download the file in multiple parts, even though they're all getting the same file from the same server.

I think there is something goofy with Opus' SFTP implementation with newer ssh servers, because I get very slow transfers on LANs or even over the Internet. For instance, I was just sending something to a FreeBSD box over the net, and only getting 20-25k/sec from Opus.

I did a commandline sftp from my Linux server of the same file to the same remote server and was getting about ~85k/sec (this is DSL).

My Opus machine is a 4-core 2Ghz Opteron system, and the Ubuntu box is a jankety old 600mhz P3.

I actually brought this up awhile back: [url]Slow SSH copies to an Ubuntu server?]

Although I am now running Opus on both XP and Vista, behaves the same way on either.[/url]

Do you see the same thing if you use PSFTP.exe from the PuTTY suite? That is fairly standard tool/suite and my understanding is that the SFTP support in Opus is based on the same code.

Hard to say, since it doesn't look like psftp spits out any kind of bandwidth statistics during or after the transfer. I'll have to try to do some manual benchmarks and try to figure out how fast it's going approximately.

I finally sat down to do a test with psftp. I sent a 6mb file which took almost exactly 2 minutes, which puts it at around ~52k/sec. Still not great, but almost twice as good as Opus did on the same file to the same server.

I have a similar issue:

Using Win XP SP3 client to an XUbuntu Virtual machine on the my laptop.

Getting average of 149k with DOpus and 2.9m with CuteFTP. :frowning:

I'm also encountering frustrating slow speeds using the "advanced ftp" functionality of DOpus. When I'm copying files from a linux box using ssh I get speeds that never are faster then 100KB/s. When i transfer the same files using WinSCP it's much, much faster.

I'm using different Linux/ssh versions, RedHat, Fedore, Ubuntu, CentOS, and every machine has the same problem.

Is there anyone with a solution? I'm getting to the point where I wonder why I spend an additional $10 for this feature, when it's getting unusable and makes me go back to WinSCP.....

If you've got a specific site that has problems and can give GPSoftware access to it so the can see the problem, and maybe experiment with changes, then that's probably the only way to see improvements.

GPSoftware's support page is linked in my signature.

thanks for the reply, but i can't give GPsoft a link to the/a site.

I'm having problems accessing linux machines in general using the ftp plugin.
I have the feeling there is a problem with the ssh (scp) connection of the advanced client, because the problem exists on every linux box i try to connect to. Browsing etc. works perfectly using DOpus on the machines, but transferring files just is really really slow....

It's easy to test this in GPsoft I think, just access a random linux machine using the ssh feature of the advanced ftp plugin and tranfser a file.....

I believe there is some confusion with the protocol being compared here. Opus does not support SCP. It supports only FTP over SSH or SFTP. This is not SCP and is a completely different sequentially acknowledged packet protocol using FTP protocols and can be significantly slower than SCP.

If you have a good SCP client that works better for you and you find the Opus SFTP too slow then I would suggest that you use your alternative program for such extended transfers.

To make it easier, it maybe possible to set up a button in Opus to call the external SCP program with the selected file parameters, but I do not know for sure.

Same here, SFTP never over 150kb/s download, I go to FileZilla and I get a full 998kb/s. The server is Ubuntu 8.04 LTS fully up to date.
I have adjusted the speeds for the account to 200kb/s upload and 2000kb/s down but it doesn't make any difference.