Video in viewer pane

Sorry - posted too hastily without answering your other questions. No, other video formats do not work, either.

I should also have said that content type is enabled as "Movies".

What about in Windows Media Player?

Looks like you are using VLC for playback which means you may not have the required codecs installed on your system for Opus and Windows Media Player to play those videos.

VLC has its own codecs "baked in" so it doesn't rely on codecs being installed for the whole system like most other video players.

Can I get the codecs from within D Opus?

You need to download and install the appropriate codecs for the video formats you are trying to play. Most likely though, all you need is ffdshow as this includes support for most common video formats.

You can get it from ... _id=173941 (I'd suggest just going for the "generic build (stable)" at least to start with)

That made no difference, I'm afraid. but I can't be absollutely sure, because the program prompted me to install a minor upgrade, and now wants a new certificate. Does this mean I have to pay again? If so, then the prompt should have said something like "Caution! You willl be charged for this update - press No to refuse it." Please clarify - and let me know how I can roll back to my previous paid-for installation.

FFDShow shouldn't ask you for a certificate at all.

Or did you mean Opus is asking for a certificate? If so then see the FAQ: Registration Certificate suddenly expires or does not stick.

You do not have to pay for minor Opus updates so if you've updated from version 9.X to version 9.Y you should not have to get a new certificate. Only major upgrades require new certificates, e.g. version 8 to version 9.

(One possibility not mentioned in the FAQ is that you're using a pirate certificate. New versions tend to block those...)

Also: You still haven't answered my question about Windows Media Player. Do the videos play in it or not?

Yes, the videos play in everything except directory Opus

And the certificate I am asked for is for D Opus.

I would fix the certificate issue before worrying about anything else.

Have a read of the FAQ I linked above.

Try simply reinstalling your existing certificate since if it's a valid Opus 9 certificate it should work.

Failing that, you'll need to contact GPSoftware with your certificate details to ask them why it isn't working.

I am now nearly there, but it has been a long haul. I have retrieved my licence from the licence manager on your website - though it is a bit of an inconvenience to have to do so. I can now sort of play videos in D Opus. But I was first given an incomprehensible warning in a window titled "AVI Chunk Manager", which I simply closed. The video then played distorted - long and thin - though recognisable. I could not close the program, because the hourglass kept spinning, so I closed it via Task Manager. I can now still hear the audio of the video file, even though D Opus is shut!

(I should have called the window AVI Chunk VIEWER.) I have just reopened directory Opus, and can play the file, again distorted in the same way. But I can now hear both the audio from the currently playing file AND from the one I closed a few minutes ago. You will probably realise that this is beginning to drive me nuts.

I have just closed D Opus in the usual way, which shut off the audio as well as the video from file 2. But the audio from file 1, the first one I opened, is still going.

The "AVI Chunk Viewer" message doesn't come from Opus itself. It must be coming from whichever video codec is being used to play the files. I'd expect the same message to appear in Windows Media Player for the same file.

If your video codecs are messed up it can be a real pain to find and fix the problem. This isn't an Opus issue but a general Windows issue. Often you can fix things by just installing FFDShow but if other video codecs are also installed then they can clash with each other and cause real headaches.

I tried stopping dopus.exe in Task Manager/Processes. It did not stop the phantom audio, which now keeps distorting - sounds rather like water going down a plughole.

My next step is to reboot. I will get back to you after that.

You said:

"I would fix the certificate issue before worrying about anything else.

Have a read of the FAQ I linked above.

Try simply reinstalling your existing certificate since if it's a valid Opus 9 certificate it should work. "

That is now fine, as I wrote earlier. But the video problem still has me tearing my hair out. I rebooted and again tried playing the file in D Opus. I did not get the AVI Chunk Viewer this time, but the picture is still distorted, and none of the controls under the viewer works - Stop, Full Screen, Settings, none of them. So I closed D Opus - this time in the normal way - and I STILL have the phantom sound. Frankly, I preferred it when I couldn't play the video at all. I wish I'd never started this - and you probably feel even more strongly the same way! If you can just tell me how to switch off this damned sound, I'll go away.

See if this small video plays in Opus:

If it does play, which of the two screenshots below looks like what you see? The look of the playback controls below the video is the important thing.

If you see something like this then the Movie plugin is displaying the file:

On the other hand:

If you see something like that (maybe with a black control bar instead of white) then the Movie plugin is passing on the file (or the Movie plugin is disabled) and it's instead being picked up by the ActiveX + Preview + Office + Web plugin. The ActiveX plugin will usually try to play movie files with Windows Media Player (inside of Opus) if the Movie plugin handle them first.

By the way, if you see (or don't see) this control bar as well as the ones shown above then don't worry about that. It's part of the Opus viewer itself, not the plugins. I just have it turned off in the two screenshots above:

To prevent movie playback completely, go to Settings -> Preferences / Plugins / Viewers and:

[ul][li]Disable Movie[/li]
[li]Select ActiveX + Preview + Office + Web and click Configure[/li]
[li]In the plugin configuration window that appears, disable Generic ActiveX at the bottom.[/li][/ul]

Doing that will disable the Movie plugin as well as the part of the ActiveX plugin which can play movies.

VLC Plugin...

A plugin which plays movies via VLC has been suggested and may be written at some point (by me or someone else interested in doing it). That will make movie playback a lot easier when the system video codecs are misbehaving.

Leo: First of all, I am VERY grateful for all the time you have spent on this, which is exceptional. I have never had this kind of superb assistance from any other program.

But I have come to the conclusion I would rather be doing something better with my life than trying to get D Opus to run a peripheral utility which it stubbornly refuses to do. We will never get to the bottom of why video played fine in version 8, and will not do so in version 9 - in my copy, at any rate - and then will play VERY badly in the updated version, and insists on maintaining a phantom audio after it closes.

I think it's time to bid farewell to Opus, with which I have had a slightly love-hate relationship over the three or four years I have been using it. I accepted the fact that the Help section seems to be designed for computer experts and is incomprehensible to ordinary Joes like me. I accepted the fact that it would regularly crash - lots of programs do that. But this has tipped the balance. I am now exploring other file management and Explorer replacement programs - some of them free - which seem to be much more manageable and don't make me tear my hair out. They are not the Rolls-Royce program that Opus is, but then again servicing a Rolls, as we have discovered, takes a lot more time and effort than looking after a mini.

So thank you again, but - no doubt to your relief - I won't be taking up any more of your time.

Last word on the viewer pane: mine looks like neither of yours, but never mind.

Fair enough.

Although, if your video codecs are messed up then that would explain the crashes as well. Opus almost never crashes on my computers and I use it almost all day. :slight_smile:

If your video playback looks like neither screenshot then my guess is there's some other ActiveX control handling the movie playback. Disabling the Movie and ActiveX plugins would solve that and may also solve the crashes (if they were due to video codecs).

If you get crashes in thumbnails mode then you'd probably also want to disable Preferences - Lister Display Modes - Thumbnails: Use Shell Image Extraction to prevent Opus from calling into Explorer's plugins to generate thumbnails, since they can also trigger video codecs to be used.