Video mpg thumbnails not showing up in Vista?

I've been using version 9.0 for awhile and most happily on XP. But I got a new computer running Vista Ultimate, 32-bit, recently which I actually like, except that I do a lot of home video editing and I'm not seeing my mpg thumbnails, even though I have the Vista Codec pack installed, which gives me thumbnails in regular Windows Explorer for just about every type of video file out there. Strangely, in Dopus, I only see thumbnails for flash (.flv) files and .avi.

Is there some adjustment I have to make in Dopus in Vista to get my vid thumbnails to match what Windows Explorer shows me?
Thanks:)

Check that the Movie plugin is enabled and, within its configuration window, the Generate thumbnails option is on.

(Increasing the Maximum time per thumbnail option may also help if the thumbnails are taking unusually long to generate. MPEG files are usually very quick though.)

If it's still not working, confirm that you can play the same movie files okay in the Opus viewer. If you can't then it might be because you're dependent on the FFDShow codec for the files you're trying to view and it doesn't have dopus.exe on its whitelist. You can fix that by opening Video decoder configuration from your Start Menu.

(When confirming that movie files play, you may wish to disable the ActiveX + Preview + Office + Web plugin since it can also play movie files via Windows Media Player and it might confuse the issue. You need to make sure playback works via the Movie plugin.)

Finally, turning on Use shell image extraction for formats Opus does not understand (see the 2nd screenshot below) should also make thumbnails for movies work, if they're already working in Explorer. That will use the same method Explorer uses to generate the thumbnails instead of having the Movie plugin generate them. (However, if FFDShow is blocking dopus.exe then it still won't work.)




Here's the relevant page in the FFDShow configuration, too.

Ensure that dopus.exe isn't in the "Don't use ffdshow in" list.

Ensure that dopus.exe is in the "Use ffdshow only in" list if that list is enabled.

(FFDShow will usually ask you if you want to use it in a program that is new to it the first time you do so.)


[quote="leo"]Check that the Movie plugin is enabled and, within its configuration window, the Generate thumbnails option is on.

(Increasing the Maximum time per thumbnail option may also help if the thumbnails are taking unusually long to generate. MPEG files are usually very quick though.)

If it's still not working, confirm that you can play the same movie files okay in the Opus viewer. If you can't then it might be because you're dependent on the FFDShow codec for the files you're trying to view and it doesn't have dopus.exe on its whitelist. You can fix that by opening Video decoder configuration from your Start Menu.

(When confirming that movie files play, you may wish to disable the ActiveX + Preview + Office + Web plugin since it can also play movie files via Windows Media Player and it might confuse the issue. You need to make sure playback works via the Movie plugin.)

Finally, turning on Use shell image extraction for formats Opus does not understand (see the 2nd screenshot below) should also make thumbnails for movies work, if they're already working in Explorer. That will use the same method Explorer uses to generate the thumbnails instead of having the Movie plugin generate them. (However, if FFDShow is blocking dopus.exe then it still won't work.)[/quote]

I never knew about those settings! Thanks for the awesome info, will try as soon as I get home:)

That did it - thank you so much:)

Really? Odd. I've been using ffdshow for years, and I have never once been asked or prompted about an application. Instead, as I would expect, if I started having problems with some application, I would just have to track it down on my own and manually update the exclusion list.

Is there some setting I'm missing in ffdshow to get it to do that?

There's just such a setting in the screenshot above. (It's disabled and turned off in the screenshot since I told FFDShow to stop asking me, I think.)

:blush: Why, yes. Yes, it is.

I only ever have used the blacklist filter, never the whitelist filter. I guess that's why I have never seen the pop-up in all these years. :slight_smile:

It's off by default, it seems. Screenshot from a fresh install I just made yesterday:

Thank you Leo - it solved my problem on Winddows 7.