View does not refresh after delete/rename

Please see this FAQ: Changes to folders are not being detected

I have debugged the problem as suggested. The notifications do not come though when I create a new file and rename it. It only has the file created but the rename does not occur until after a refresh. The rename DID happen but no notification .

What type of drive is it?

Are you doing the rename/delete in Opus or in something else while Opus watches?

Does Windows Explorer see the changes?

Thanks for the quick reply. I have tested it on my SSD and my NTFS physical. I am doing the rename/deletes in opus. This is also persistent in explorer, though I hadn't used it in ages.

If it affects local drives in Windows Explorer as well then it must be an issue at the filesystem or operating system level. Opus can only respond to the events the OS sends it, but the OS is apparently not sending those events to Opus (or Explorer).

After uninstalling Opus I no longer can reproduce the issue in explorer. It seems opus interrupts something. I wanted to confirm this so i re-installed pro with default settings and the issue persists. When I mentioned this happening in explorer I meant to say that I can see the issue in explorer but not create it there. I can create a new folder which gets named "new folder" waiting for a name. If i type "zack" for the next name of the folder on both opus and explorer I see "new folder" until I F5. I also can try to delete the "new folder" and it does not exist. I tried with without the opus new folder macro(alows you to make multiple folders) too and it doesn't work.

I did even more testing and have found the sequence of events that triggers this. Use the new>newfolder which created a folder called "new folder" when you rename this while still selected the rename does not take place. Any delete tried before an F5 will try to delete "new file" regardless of the name. Using Opus new with brings up a dialog to create a folder did not have these issues.

Main issue: new > new folder - doesnt pick up new name or refresh

Opus could not affect Explorer's ability to respond to folder changes. There's no connection or interaction between the two at that level. So if Explorer also (sometimes) sees the same problem, it points to something lower level than Opus or Explorer.

If junctions / softlinks / etc. are involved anywhere in the path to the folder you are testing in then that might explain things, as they can confuse the change-notification system sometimes.

I have confirmed that it is an Opus only issue as it CAN NOT be produced in explorer. The only thing that explorer can do is also not know to update. If the action happens in explorer explorer updates. I have uploaded a small avi video to youtube( that displays this issue. The video does not have sound but it shows the creation of folders and the error that occurs because there is not a refresh. I can upload one of me doing the same thing in explorer, when Opus is not running, in the same folder (or different / different disk) and this issue is not present.

problem by myself and other German user confirms.
no update in folder structure for different activities

In your video, Opus is renaming the folder, but Windows is then not telling Opus that the folder has been renamed (which Opus relies on in this situation).

The rename works, but the change notification does not come through.

From what you've said (but not shown in the video), the exact same problem affects Explorer as well: Opus renames the folder, and the rename succeeds, but Explorer does not get informed that the rename took place.

Whether or not creating a folder in Explorer triggers the same problem doesn't matter, although it is interesting and seeing what the two programs are doing using Process Monitor could provides a clue as to why one rename is not generating a notification and the other is; e.g. they may be renaming different file paths. Opus is successfully renaming a folder, and Windows is then not telling anything (neither Opus nor Explorer) that the rename took place.

That points to a low-level problem somewhere, blocking the change notifications from working for some successful renames.

Is there anything unusual about your desktop folder? e.g. Is it a junction pointing to the real folder on another drive, to save space on the system drive?

What happens if you use the folder tree to go to the actual C:\Users\Zack\Desktop folder (instead of the top-level Desktop virtual folder) and do the same thing there?

[quote="Nobmen"]problem by myself and other German user confirms.
no update in folder structure for different activities[/quote]

In exactly the same situation? "For different activities" suggests not. If not then let's not conflate the issue this thread is about with what is likely to be an unrelated issue (or issues). There are many reasons that change notifications can fail (in both Opus and Explorer, and any other program that monitors for changes). The FAQ on file change problems is the best place to go for similar errors, and if you have anything specific to report please use another thread and post details of exactly what is being done and how it fails, as well as the debug information that the FAQ mentions.

think so

update work with and beta 0.1 to 0.9 properly
does not work properly with 10.5!

home (all final and beta, dopus installed) = win 7 64bit home (64gb SSD) + win 8 pro 64bit (64gb SDD)
work (from 10.2 to 10.5) = win 7 64bit pro (domain, network, 250 GB HD, dopus installed) + server 2008 64bit (raid system, dopus portable) = lots of problems (copy slow and no reaction) in 10.5! (work on 10.2!)

info: (where it occurs)
mostly in sync (to remove something from dual in the left window)
rename (list with pretended)
delete = over 8 folders (partially deleted)

(Update) ok in folder structure after f5 or existing icon switch!

Very little changed between and, and the changes we made were very isolated and conservative, so I'd be incredibly surprised if there was an impact on change notifications from that update.

We would not have changed anything that fundamental without putting out at least one more beta version before the non-beta 10.5 release.

It's more likely something went wrong the last time you rebooted to install the update than anything due to the update itself, if we are talking about updating from to Try rebooting again, just in case.

None of what you mention is to do with the right-click > New > New Folder menu, which this thread is about. In particular, that menu renaming folders such that neither Opus nor Explorer is notified of the new name, so far only seen on one person's machine.

This thread is about a very specific issue. It is not about change notifications in general.

Please do as I asked above and follow the FAQ on change notification problems, run the debug steps, and then when you have the information from those debug steps and can give us a list of how to reproduce what you are seeing, post that in a new thread.

When you do please put the new post link here.

I have uploaded another video that shows once Opus is closed the issue goes away. I love Opus and dread having to use Explore, but as you can see its not as far as i can tell a windows issue

The video shows that neither Opus nor Explorer detect when a folder is renamed by the other (and Opus sometimes doesn't detect when it renames the folder itself).

Around the 1 minute mark, you create a folder in Explorer and then rename it, and Opus does not see that rename. (You've got "This works" on the Explorer side, but the Opus side is still showing "New folder".) So both Opus and Explorer are missing out on change notifications, and both Opus and Explorer are triggering the problem as well.

In the cases where it works for either program, I suspect they are not relying on change notifications. If they rename the folder themselves, they know the name has just changed and can short-circuit waiting to be told about it if they want to. They should not have to do that, but they can, and that could explain when it works.

It could also be something more strange, like the rename actually taking place after the Rename API returns, so depending on the timing of things the folder still has the old name when the programs check for it. I've never seen that happen before but I guess something low-level like an antivirus tool could cause that. (Stranger things have happened with antivirus.)

Have you tried this in other directories? Specifically, directories that are not below your Desktop or User Profile area? Try in C:\ or C:\AMD, for example.

If you create and rename a folder using the Command Prompt, do Explorer and/or Opus see the changes?

What if you open Notepad and use its File -> Open dialog to create a folder? Does Explorer and/or Opus see that change?

Have you tried booting into Safe Mode to see if things behave differently then?

I do not run antivirus as I have had issues with development and an anti-virus.

Using another directory made no change. I used C:, C:\ADM, and I also tried a secondary disk.

creating fodlers in a batchfile/cmd prompt using "mkdir" picks up the changes in Opus and explorer.

When I used notepad's open to create a new folder I got the same error the occurred before (as if the new was done in an explorer window).

I want to reiterate this one more time, I shutdown Opus and explorer acts normally (no errors)


I don't know what's causing it. Whatever it is affects both Opus and Explorer on your system, and can be triggered by both Opus and Explorer on your system. So I do not think Opus is the cause, even if it is one way to trigger it.

I'll try again to explain why I don't think you can conclude that from the tests/results so far:

When Explorer renames the new folder, Explorer sees its own rename but Opus doesn't see it. (Explorer probably sees it because it is not relying on change notification here. It knows it renamed the folder so it is "telling itself" about the change rather than waiting for Windows to tell it.)

When Opus renames the new folder (in the file display), neither Opus nor Explorer are notified of the rename for some reason.

If you then exit Opus, how are you testing anything? Testing how Explorer reacts to itself is no good because you already know that Explorer sees its own change whether or not Opus is running.

That's good, it rules out virtual folders, junctions, and other potentially weird things.

mkdir isn't the right test; the problem isn't with creating a folder (everything sees the "New Folder" item appear). The problem is with renaming a newly created folder (things don't always see "New Folder" get renamed to something else).

Try creating and then renaming a folder using a command prompt, while Opus and Explorer are both looking at that folder. If that reproduces the problem in Explorer, you can then try exiting Opus to see if it still happens in Explorer and test your theory that Opus is somehow involved with what Explorer sees.

It does seem to be a window's issue that is know but no good solution is out there. I will post a link if I find anything relevant.