Viewer hogging file associations

Every time I open a .psd file, the viewer opens it instead.

I've change the file associations in windows 11 but the viewer still takes over.

I've checked Under Settings > Preferences / Viewer / Plugins and there is no .psd extension.

How do I stop the viewer from loading .psd files?

Remove .psd from the Images file type group, or set the .psd type to run photoshop on double-click. Either of those will only affect PSD files and can be done via Settings > File Types.

Alternatively, turn off the Preferences option for the viewer to handle double-clicks on files. That would affect all image types.

The PSD file is not listed in the image file group.

I can't find the setting to double-click to tun the .psd file.

I don't want to turn off the viewer double-clicks on files.

Type PSD into the search field at the bottom of the File Types dialog. Double-click the PSD type it finds, then go to Commands / Events and double-click the Left double-click event. Set it to run something like this:

"C:\Program Files\Adobe\Adobe Photoshop 2024\Photoshop.exe" {filepath$}

I had to add a PSD to the file types.

I edited the command/Events and it works.

Thanks Leo.

Strange if Photoshop is installed; it would normally create the type.

You told me to remove it, in your first instructions.

Leo suggested removing the .psd filetype from the Images Filetype Group (i.e. remove the extension from the list of extensions in the group), not delete the filetype itself :slight_smile:

2 Likes