Viewer shows hex for all video

JPG ok.

Can't move ActiveX plugin below Multiview, which is third from the bottom.

Multview - Configure - says "Viewer DLLs could not be located."

What to do?

The Movie plugin is the one you want to concentrate on for playing video, not ActiveX (which should ignore video files unless you've added their extensions to its configuration, in which case it might do a bad job at playing them or might ignore them) or MultiView (which will always be checked after the Movie plugin).

If you can play the video in Window Media Player than you should be able to play it in Opus via the Movie plugin. Do the files play in Media Player?

Yes, the videos play in Media Player.

What file extension does the video have, and which video codec is it encoded with?

Took to computer tech re sound, some other things, now works. Mystery. Thanks for your attempts.

I have this problem too, with WMV files. I have a rather new installation of DOpus so all my plugin settings are default.

Specifically, WMV files are configured to be viewed by the Movie plugin. Yet when I try viewing WMV files, I get a view of either the raw content of the files, or a hex view. These files play fine not only in Windows Media Player, but in other players as well, and also in XYplorer.

My MultiView plugin was unchecked by default upon installing DOpus. When I selected MultiView and clicked Configure, I saw the Viewer DLLs could not be located message. I went to this post after seeing it referenced in another thread, but that post seems to imply that MultiView obviates... Something else. I downloaded pdqvp.dll anyway, but even when I try pointing to it in the MultiView plugin configuration, the OK button does not become enabled.

Does the MultiView plugin ever work? Why is it there at all? Why don't these WMV files play by the Movie or MultiView plugins?

The info at the top of this FAQ about MPEG, AVI, MP3 and WAV ("may apply to WMV and WMA files as well") may fix the problem with WMV in the Movie plugin.

As for the MultiView plugin, it requires 3rd party viewer DLLs which Opus doesn't ship with. If you don't have the DLLs then it's of no use, but if you do have them (e.g. via Yahoo Desktop) then it's a bonus.

Opus doesn't ship with the MultiView DLLs because the company who makes them wanted to charge ridiculous royalties for them.

I fixed the problem. I ran Windows Media Player, went into Tools > Options > File Types, then checked the Windows Media Video File (WMV) file type and clicked OK. Then, WMV files began working in the DOpus view, by way of the Movie plugin.

I thought this would mean that I'd have to use Windows Media Player to play WMV files (something I do not want), but I was happy to find that I could then uncheck the Windows Media Video File (WMV) file type and click OK, then verify that my other video player (Media Player Classic) was associated with WMV files. Even after undoing the association of the Windows Media Video File (WMV) file type with Windows Media Player, I was still able to view WMV files in the DOpus viewer.

Given that it wasn't the file association itself that did it, I wanted to determine what changes had been made to enable WMV files to be viewed in DOpus using the Movie plugin. I found, definitively, that the following registry change was made by the steps above, and it is what (in this case) makes or breaks WMV files in DOpus:

[code]Windows Registry Editor Version 5.00

"Content Type"="video/x-ms-wmv"[/code]
I found that if I deleted the Content Type value, WMV files would no longer view properly. If I added it back, WMV files worked again in DOpus.

A few other registry changes were made (i.e. the PerceivedType value was also added, with data set to video), but none were essential to viewing WMV files in DOpus.

I hope this helps...

Oh and by the way, thank you very much, nudel! I was so busy digging through the registry that I forgot all about common courtesy. :blush:

Rather than "i.e. the PerceivedType value..." above, I meant "e.g. the PerceivedType value...". I can't believe I mixed up "i.e." and "e.g." but there you have it. (It does matter, beyond pure pedantry, because PerceivedType was not the only other value created.)