GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Viewer stopped working



I have recently built a new computer running windows 10 with Directory Opus 12.9.
last night the viewer window stopped showing videos, the movie plugin is running but only audio is played (viewer remains black).
All videos do play in all other players, I have uninstalled and reinstalled several codecs but nothing seems to fix this problem.

Please help


The way the plugin works has not changed in a long time, so the difference must be something on your PC.

If you've already tried the codecs etc. mentioned in the FAQ on this issue (n.b. remember you need the 64-bit versions of codecs/splitters for Opus's Movie plugin), then the easiest thing to do is disable the Movie plugin and fall back on the Windows Media Player ActiveX control or preview handler.

Both can be accessed via the ActiveX+Preview+Office+Web plugin, where the ActiveX control is the default; configuring the plugin will show you an option to turn on the preview handler instead. The main difference is that the preview handler is click-to-play while the ActiveX control is auto-play.

If they do not play videos either, make sure Windows Media Player is working for the same files.


Thanks Leo, yes I have tried disabling the movie plugin and using ActiveX. this does work for all videos.
But I prefer the way the movie plugin works (black background with auto play).
With any combinations of codecs and splitters, I get the same result, (audio plays but no video)

I agree that something on the PC outside of Dopus has changed, The only change I made last night was to install codecs, I have since uninstalled them and the problem remains.

Have you seen this problem before?
Do you have any suggestions as to what may have been changed when I installed K-lite codec pack, and is not undone when K-lite is uninstalled?


Video codecs and codec packs can be a mess to clean up. Depending on what has been done on the machine, it might be a mess that's unique to your particular machine. It's hard to say what to do, beyond the advice we already have in the FAQ.


I now think this is a bug in Dopus. I have reinstalled windows 10, 6 times, to test what breaks the viewer window.
I found that on a fresh install of windows with only Dopus installed, some video formats would not play, I installed k-like codec pack and all videos worked in dopus.
After viewing 5 or 6 videos the viewer window would break, (audio will play, time line moves, viewer remains black) uninstalling codecs would not fix the problem.
I did have some success when I installed win10+dopus+shark007 codec pack. this had been working since last night, until just now.
I minimised dopus while it was playing a video and now the viewer windows is broken again. (audio plays but no video)
I do not think this is a codec issue, as all videos play in all media players, and have been working in Dopus too.
once the viewer glitches, it seems there is no getting it back, without reinstalling windows.
reinstalling Dopus, reinstalling codecs, restore points, nothing fixes the viewer function.
This is very frustrating, as this is one of the features I like, and one of the reasons I paid for Dopus.


The viewer itself won't do anything different when it plays the first video or the sixth one so I am not sure what is going on there.

Codec packs are something I try to avoid as they often have problems and complicate things vs just installing the one or two codecs/splitters you really need.

Remember that the Movie plugin in Opus uses 64-bit codec/splitter DLLs. Most movie software uses 32-bit ones, which won't be testing the same components Opus uses. It also needs to be a video player that uses the system codecs and not its own private ones. There aren't actually that many tools which use the 64-bit system codecs like the Movie plugin does. (Maybe we should make that plugin 32-bit, since we have the ability to do that the same way the ActiveX plugin can host 32-bit ActiveX controls and preview handlers.)

If you run C:\Program Files\Windows Media Player\wmplayer.exe you should get a 64-bit version of WMP which is a good thing to test with. Make sure it is a 64-bit process using Task Manager, and not just bringing an existing 32-bit version to the front. And be sure to run it via that path, not via the Start Menu etc. since they will launch the 32-bit version of wmplayer.exe by default.

Some codec packs only have 32-bit DLLs, and some both 32- and 64-bit but in different versions.

What happens if you don't install any codec packs? Does playback of the videos which worked continue to work after multiple videos have been played, and only start to go wrong once the codec pack is installed?

Which formats are you finding you need a codec or codec pack for in Windows 10?


I agree that software should not behave differently after 1 or 100 plays, but this is happening time after time.

I have a folder which I have been using for testing, it contains 1 each of, .ts, .mkv, .mts, .webm,.mp4, .wmv, .flv., .avi.
Dopus viewer is now glitched again, so Its hard to say what does work, but right now.
All third party codecs are uninstalled and all formats play in wmplayer (64bit) except for .flv.
in Dopus, the following formats play but with no video, .mkv, avi and .wmv. all other format now display code in the viewer (unrecognised). all the above file extensions are listed in the movie plugin.

When the viewer is functioning correctly, I can see that different codec's are running for the different formats, it seems that this switching between codec's is causes a problem, maybe a incompatible codec is called up causing a glitch and then that codec somehow becomes the preferred choice, so videos will not play again.

During a previous test, I found that quartz.dll was being called up to do the video rendering, and this was giving the same results as Dopus Viewer (audio with no video, black screen)
when I changed the default video rending to a different codec. video would play correctly every time in Graphstudionext64. but this did not fix the problem in Dopus.

I would have to wipeout windows again to do more testing to give a correct answer to what will play on a fresh install, I didn't take notes.


I have had some success tonight, installing an older version of the nvidia display drivers has restored the viewer functionality. fingers crossed it keeps working.


What version of the nvidia drivers are you using? I think I am running into the same issue you are having.

UPDATE: I installed display drivers from several months ago and my preview is working again. Is there anything I can provide to help debug this issue? I do like to game and would like to keep my drivers up to date :slight_smile:


I'm using version 391.35 and everything is still working well in Dopus.


NVidia are the best people to report that to.