Viewer unable to open images from OneDrive using files on-demand

When I try to open images that are stored on OneDrive, but not synced to local storage (using files on-demand feature), using Dopus image viewer, viewer launches but displays the message "Unable to load picture_name.jpg as a picture". If I sync this picture to the local storage - Dopus Viewer is able to open it. At the same time Dopus can open other, non-synced, types of files (.pdf, .docx, .xlsx, etc.) without any problem. If I try to open image file using Windows 10 Photos app, from the Dopus - it opens not synced images just fine. I have checked Windows settings and it looks like that I have not blocked Dopus from downloading files from the OneDrive (then again - this issue manifests when opening image files, other types of files are downloaded just fine). It started to happen 7-9 months ago, previously it worked just fine. Please help in solving this issue.

OS: Windows 10 20H2
Dopus: 12.24 x64 Build 7795

I've tried two different machines and it's working OK on both of them, assuming "files on demand" corresponds to having "Available when online" in the Availability column (or a cloud icon in the Status column), as you get if you right-click a one-drive file and choose "Free up space".

How are you launching the viewer against the files? Double-clicking inside of Opus, or something else?

Is the preview pane the same?

I was able to "fix" it just now, by running Opus with administrative privileges. Not sure if this is a "hard" requirement now, in order to be able to open images specifically, or it was like this from the beginning and I just have forgotten about it.

You are correct regarding file availability attributes. I'm trying to open images by double clicking inside Opus. Preview pane is just empty, without any notifications. But everything works if I launch Opus with administrative privileges. Is this the only way? I would prefer not to run it like this on a constant basis.

I don't have Opus running as admin, and you shouldn't need to. (You also shouldn't, in general, as it'll cause other problems: Why NOT to run Opus as Administrator under UAC)

My guess is something is messed up on your machine regarding permissions, or possibly antivirus is screwing things up somehow and not getting involved when the process is elevated.