Vista RC 2 & Dir Opus

RC2 build 5744

I installed Dopus V6 as I did with RC1 5600, then installed DOpus V8 over the top, but setting Compatability mode to Windows XP SP2, DOpus works perfectly.

But you still need to install V6 first because Vista is still breaking InstallShield, or did you not try installing V8 without V6?

Has anyone beta testing Vista reported the InstallShield problems to MS? (I presume so since it doesn't just affect Opus. I hope so since otherwise Vista's going to be more painful for everyone than it has to be.)

Well, the "works perfectly" is really only true if you don't start touching the miscellaneous preferences, tab explorer replacement.

DO worked when I installed it, and then I imported a settings file to match the configuration I have on XP.

At this point, clicking on control panel in the start menu gave me an error (something like "class {xxx-xxxx-xxxx-xxxx} not found") and most other "special" folders also failed to open.

Of course, reverting the setting back to "Don't replace Explorer" doesn't fix the problem. I haven't tried to uninstall DO yet. Last step before reformat / reinstall of vista.

Well I had to reinstall vista. After the DO uninstall, some folders wouldn't open anymore, even though I wouldn't get the error message. Clicking control panel would not do a thing anymore.

After my reinstall and without having DO associated to any folder types (I'd rather play it safe) I have another problem; I can't open the file properties anymore.
Contextual menu / properties on any kind of file spawns an error Titled "Desktop" and saying "The properties for this item are not available".

Of course properties are available from explorer.
It also works from TotalCommander (yes I know, low blow)

Well I'm using RC2 in anger (i'm developing and testing our own softwarep products on it) with DOpus. I've avoided running it as a replacement and things don't seem too bad.

As for installshield - try installing outside of program files - note that it installs quite a few more files (but not all of them) - it's possibly a permissions thing as Vista is a little different in this respect. My other comment would be "why are you using installshield?" Personally i think it's rubbish and i'd recommend the excellent NSIS from Nullsoft - it's completely free AND it works flawlessly on Vista (and anything else). We recently dumped Installshield and rewritten our installer using this (and trust me when I say we have some very complex install requirements).
Just a thought.

After running the installer (in compatibilty mode) i simply copied the dir from my XP partition and that seemed to do the trick. The File->properties thing is annoying but i'll live with it. I've got UAC disabled btw.