GP SoftwareTwitter
Opus FAQsManualCommandsObjects

.wav files not playing in internal player

Up until now I have been able to play all .wav files that have come my way by double clicking in Opus, and still can, except some files won't play.

These won't play:

(.wav extension)
CCITT A-Law
64kbps
8kHz
8 bit
mono

The above shows in the box that opens over Opus when file double clicked. It opens this box, but nothing happens.

Any ideas?

They do play in Window Media Player, but this is a bit slow.

Is there an example file somewhere we can try with?

Leo,

How do I attach? I get an invalid file extension error message when I drag to this window.

Same thing happened earlier with pdf and Word files.

Try Zipping the files.

Zipped file attached.
24.03.16_09.19_Call.0882282999.zip (46.3 KB)

I've been looking into this today and it seems some parts of Windows will play the file while others won't.

It looks like the API used for the basic Play window in Opus will not play it, at least without adding an extra component, so we'd probably have to re-write that to use another API for it to work with the file.

However, if you just need a quick way to listen to these files while in a folder, you can use the viewer pane and it's potentially better than using the Play window as it is easier to switch between files.

To do this, you'll need to disable the WAV plugin under Preferences / Viewer / Plugins. (The WAV plugin just displays thumbnails of WAV files; it doesn't play them.) After doing that you should find that WAV files play in the viewer pane using an embedded instance of Windows Media Player, which will handle the format.

That's ideal if you want the files to auto-play as soon as they are selected, if the viewer pane is open. If you would prefer to have to click "play" in the viewer pane instead of them playing automatically, go back to the same Preferences page and configure the ActiveX + Preview + Office + Web plugin, then enable Preview Handlers / Windows Media Player at the top. That will make it use WMP via a different route, which is click-to-play.

I am having an issue where some .WAV files will play through the internal player, and other's won't. I reviewed this post:

However, I am unable to determine a solution from that post. I changed the preferences setting per Leo's post to this topic dated 6/9/16. Double-clicking the .WAV file in question launches the internal player, but then nothing happens, and the play controls are grayed out.

The original .WAV file that plays is from a recording of my band done in studio in the area here. The .WAV file I'm having problems I edited in Audacity. DOPUS plays the original .WAV file, but won't play the edited file attached. (I did not load the original file ~ 18MB.)

I am able to right-click on the file and play through Windows Media Player.

DOPUS V12.6 64-bit, build 6369.

Any suggestions?
Thanks.

KBQ demo - A Song For You 50s.zip (8.1 MB)

That file plays fine here, and looks like a standard 44.1kHz, 16-bit PCM wav.

Was Audacity still open when you double-clicked it? If the file was still open for editing, that might prevent some components from playing it.

You are correct: the files was open in Audacity. When Audacity closed, .WAV file plays.

Duh. Thanks for solving.
Karl

Sorry to necro, but I seem to be having the same problem. Here is a freshly exported file from Adobe Audition, and even if I close Audition, it won't play:

https://www.dropbox.com/s/qwf4g70rjht3yna/volcano%20d150%20edit%20200730%20v1.wav?dl=0

Looks like a 32-bit floating point wav file, which is quite rare. The internal player won't play those, but the Windows Media Player activex player and preview handler both will, if you disable the Wav plugin and use the viewer pane. From above:

1 Like