What changed?

I need help with reading contents of a network storage drive. This feature was working. I could read the directory and manipulate the directory. Now when I try to open the NAS drive (double click on the icon) - I am sent to the configuration page of the drive (using IE). I have searched the FAQs bit I don't what to look for in finding the solution. I am embarassed that I don't know how or what to ask!? Something changed and I don't know what.

What kind of NAS do you have.
I have a ReadyNAS and get the same issue if I don't have the RAIDar software for the NAS installed. So maybe your PC is missing some software on it?
Mapping and typing the address (not browsing) to the shares on the NAS still work though, even without the software installed...

Does the same thing happen when using Windows Explorer?

Which version of Opus are you on?

I had time to look at this again. I had been using Powerdesk 8 for directory work for years. At times, it could be slow on network situations and it's command options are not as great as Opus. I used Opus with my Amiga (wonderful memories of hardware and software). It will take time to become proficient with windows Opus. There are so many more options than before.

I tried any kind of access to the NAS. I tried Powerdesk again. Powerdesk was now unable to read the directories. Short story to solution. I turned off the Dlink 323 NAS and turned back on. Powered on/off my network switch. Now, different options/icons appeared on Opus and I was able to access the directories. Powerdesk worked again too.

Thank you so much for the quick attention. Most often - It is the basics that trip us up rather than the complicated!