GP SoftwareTwitter
Opus FAQsManualCommandsObjects

What commands need to register in Everything to open a search in Directory Opus?

Hello!
Everything in Windows Explorer works fine.

  • With a double click on the path, it opens the path, highlighting the object.
  • With a double click on the name of it (opens, unpacks, launches):
  • if this folder opens it
  • if it is an archive then unpack it
  • If this is a video or text document, it opens
  • if .exe then runs
    The default settings are:
  1. Open (Folders)
    $exec("%1")

  2. Open (Files)
    $exec("%1")

  3. Open Path
    $openpath("%1")

  4. Explore
    $exec("%SystemRoot%\explorer.exe" /n,/e,"%1")

  5. Explore Path
    $exec("%SystemRoot%\explorer.exe" /n,/e,/select,"%1")
    2019-01-05_115543
    Here's a video
    https://resource.dopus.com/uploads/default/original/3X/1/6/16cc99d5338179d3a8c338417ed1965f40870202.mp4
    I made the following commands:

  6. Tools > Options > Context Menu > Open (Folders) > Command
    $exec("C:\Program Files\GPSoftware\Directory Opus\dopus.exe" "%1")

  7. Tools > Options > Context Menu > Open (Files) > Command
    $exec("C:\Program Files\GPSoftware\Directory Opus\dopus.exe" "%1")

  8. Tools > Options > Context Menu > Open Path > Command
    $exec("C:\Program Files\GPSoftware\Directory Opus\dopus.exe" "$parent(%1)")
    I tried these
    $exec("C:\Program Files\GPSoftware\Directory Opus\dopus.exe" "%1")
    $exec("C:\Program Files\GPSoftware\Directory Opus\dopus.exe" $parent("%1"))

But it does not work for me as in Windows Explorer (video above).
With a double click on the path, it does not select the object
With a double click on the name, not everything also works:

Does this have what you need?

Leo Thank.
I read this and I did the button too.
2019-01-05_124132
I would also like to know which commands in Everything should be written if, for example, the button is not used.
Here I still asked, but there is no solution yet.
https://www.voidtools.com/forum/viewtopic.php?f=5&t=7366

For "open path" in Everything I use:
$exec("C:\Program Files\Directory Opus\dopusrt.exe" /acmd Go OPENCONTAINER PATH "%1")

It opens a lister or tab and focuses the file passed.
All others are default as I have explorer replacement for Opus and it handles them correctly.
I hope this helps.

It helped me
Go to Menu> Settings> Customize Toolbars ...> Commands
plus click on User-defined Commands (xx)
in the first line after the header will be Add new User Command ..., click the right mouse button.
there will be a menu with paste, the following code should be inserted there.
The everything command will appear in the list (do not change the name, it will search for a command from the everything program)

<?xml version="1.0" encoding="UTF-8"?> 
<button backcol="none" display="icon" textcol="none"> 
   <label>everything</label> 
   <template>filepath,filename</template> 
   <icon1>#usercommand</icon1> 
   <function type="normal"> 
      <instruction>Go LASTACTIVELISTER</instruction> 
      <instruction>Go PATH="&amp;filepath&amp;" NEWTAB=deflister,findexisting</instruction> 
      <instruction>SELECT NONE</instruction> 
      <instruction>SELECT PATTERN="&amp;filename&amp;" DESELECTNOMATCH MAKEVISIBLE</instruction> 
   </function> 
</button>

go to settings everything
Tools> Options ...> Context Menu> Open Path> Command
insert the command Apply Ok

$exec("C:\Program Files\GPSoftware\Directory Opus\dopusrt.exe" /acmd everything FILEPATH="$pathpart(%1)" FILENAME="$namepart(%1)")

Thank you, but it does not work for me for some reason.

Tha path to your dopusrt.exe is different from mine.
It's inside the dopus directory.
Fix it and it should work.

Why is the path correct?


Still:
SearchEverything: Getting Opus to work with Everything v4.0 SearchEverything v.4.0.0.0.rar
It is better to add this to your code, then it will always open in a new tab.

<instruction>Go NEWTAB</instruction>

it will turn out like this

<instruction>Go NEWTAB</instruction>
<instruction>C:\Program Files\Everything\SearchEverything.exe &quot;{dlgstring}&quot;</instruction>

FWIW

I have added:
$exec("x:\Directory Opus-path\dopusrt.exe" /acmd Go NEWTAB PATH "%1" tofront)

in my case:
$exec("D:\Directory Opus\dopusrt.exe" /acmd Go NEWTAB PATH "%1" tofront)

under Everything > Options > Context menu > Explore Path

SnagIt-04032019%20094953

Go NEWTAB PATH "%1" tofront should be Go NEWTAB=tofront PATH "%1" in both cases.

Thanks Leo.
Maybe I was lucky, but how I -had- it, one way or the other, worked as well.
Corrected the everything settings.
Thanks again.

Question: Can
Go NEWTAB=tofront PATH "%1"
also be combined with:
Go NEWTAB=findexisting ?

Thanks.

Go NEWTAB=tofront,findexisting PATH "%1"

As always, many thanks indeed!