GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Windows 7 no-extension file open in Explorer but not in Dopus

I have configured the Windows 7 registry to open no-extension files with emacs via
"c:\program files\emacs\bin\runemacs.exe" "%1"
Left-clicking in Windows Explorer on a file with no extension opens the file in emacs.
Left-clicking in Dopus on a file with no extension pops up a "Chose the program you want to use to open this file" window with emacs as the only choice.


The Windows Explorer context menu for a no-extension file show "Open" at the top.
The Dopus context menu for a no-extension file shows "Open With ..." at the top.

How do I get Dopus to open a no-extension file directly?

Solved ...for the most part.
Dopus pops up the ""Chose the program you want to use to open this file" window when the no-extension file is empty with a zero byte-count. Placing a text-type ASCII code in the file causes Dopus to open the file directly without popping up the "Chose the program you want to use to open this file" window. But the ASCII code is not a text-type (for want of a better descriptor), say the code 0x00 or 0x07, Dopus pops up the unwanted window. I found also that if the code 0x00 is placed in the middle of some text, Dopus sometimes opens the file directly and other times pops up the unwanted window.

Preferences / File Operations / Double-click on Files / Open unregistered file types in text viewer if they appear to be plain text... is probably what you want.

The start of the files must look like text data for it to apply to them. 0x00 never appears in text data.

Thank you for the Preferences / File Operations / Double-click on Files / Open unregistered file types in text viewer if they appear to be plain text tip.

Strictly speaking, 0x00 may never appear in text data, but it certainly appears at the end of null-terminated strings.

Only when strings are included in other binary data; never in text files.

I'm still having trouble opening extensionless text files with Dopus. In Windows Explorer extensionless files open readily with my registry-designated no-extension editor (emacs), but, alas, not in Dopus. Instead of opening an extensionless text file Dopus takes me to the directory

C:\Program Files (x86)\emacs

where there are five subdirectories, one of which is bin/ and contains the emacs launch program runemacs.exe.

Trying to open empty extensionless files in Dopus pops up a Windows open-with window with a single entry for Recommended programs: emacs. No other entries are present in the popup.

Why does Dopus take me to the C:\Program Files (x86)\emacs directory and what can I do to coax Dopus to open extensionless files using my designated editor?

Here is the registry-exported entry for No Extension.

Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\No Extension]
[HKEY_CLASSES_ROOT\No Extension\Shell]
[HKEY_CLASSES_ROOT\No Extension\Shell\Open]
[HKEY_CLASSES_ROOT\No Extension\Shell\Open\Command]
@=""C:\program files (x86)\emacs\bin\runemacs" "%1""

Windows 7 Pro SP1

Opus does not currently support the use of a "No Extension" file class like this.

In the Opus FileType editor you can configure the behaviour for Unknown file types which should give you the same effect.

Thank you for getting back to me, Jon. Alas, I can't get your instructions to work. when I carry out them out, using the command you displayed,

"C:\Program Files (x86)\emacs\bin\runemacs.exe" %1

(attachment 1), Dopus does not launch emacs to edit the file. Dopus continues to take me to directory containing the link to the emacs directory (attachment 2). The "emacs" in the command is a link to the emacs-24.4 directory. When I bypass the link by using the command

"C:\Program Files (x86)\emacs-24.4\bin\runemacs.exe" %1

(attachment 3), I again get shown the emacs link (same as attachment 2), not to the emacs-24.4 directory.

Surely I'm doing something wrong. What do I do to get Dopus to open an extensionless file in emacs?

The %1 normally needs to be in quotes -- i.e. "%1" -- or it won't work properly when the file paths contain spaces.

Emacs may be different, though. This is just a general rule with most (Windows) software.

I suspected that quotes were required about the "%1"; I copied Jon's advice verbatim in case Dopus handled arguments in an unusual way. Placing quotes around "%1" makes no difference. Dopus's behavior is unchanged from my previous report. I end up in the c:\Program Files (x86)\emacs directory every time, even when I've assigned the Unknown file types left double-click command

"C:\Program Files (x86)\emacs-24.4\bin\runemacs.exe" "%1"

This behavior is especially puzzling. I direct Dopus to the emacs-24.4 directory and it ends up showing me the emacs link and the emacs-24.4 directory contents. Why is Dopus showing the the emacs link?

Moreover, what do I try next to get Dopus to open unknown file types with emacs?

Change the command to Help ABOUT.

Does the About window open when you double-click one of these files?

If not, the command being run isn't the one being edited. (Or you haven't pushed OK to save the changes. You need to click OK in the command editor, and then in the file type where it lists the commands.)