Windows search not working

Windows search does not seem to be working. I enter a word in the filename of an open folder and nothing is found. Tried including "filename:XXX"; doesn't work either. No problems with Windows Explorer or with Opus Find Files, just the Windows search in upper right side of lister..

A screenshot of exactly what you're searching for and what's in the folder might reveal something.

Microsoft have also been breaking Windows Search a lot in various ways recently in Windows 10 updates, so you may just be running into one of their bugs. There are some other recent threads on the forum with workarounds which worked for some people (turning on or off indexing for certain folders was one, I think) but using the internal Find Files panel is also easier and avoids Microsoft's shoddy code entirely. :slight_smile:

Wow! Really quick reply!
Here are some screen shots:

Thanks for your help!


Forgot to explain what screen shots were.
First is folder showing files to be searched (for a word in filename).
Second is search result (empty) after searching for a word in filename.
Third is search result (empty) after searching with "filename:.html"