GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Windows shortcut Key in Vista


#1

I'm used to using (Windows Key) + E to start opus on XP. On my Vista system it starts Explorer. In other respects Explorer replacement is working fine.
Apologies if this is covered in another thread - I wasn't sure what to search for.


#2

Win-E starts Opus here, in Vista, so it should work. (Unless you're using 64-bit Windows, perhaps.)

Check in Preferences that Explorer Replacement is turned on and that it doesn't exclude Computer (My Computer).


#3

I have 32 bit Vista Home Premium.
Windows-E starts Explorer, as did Opus 8.
Originally I had Opus 8/XP, (Win E was OK). This was upgraded to Opus 8/Vista (not OK - but I assumed this was cos Opus 8 did not claim to support Vista, so ignored it) then Opus 9/Vista.

In preferences I have "Replace Explorer for all file system folders".


#4

That's not good enough, you have to set it to Replace Explorer for all folders.


#5

That's not good enough, you have to set it to Replace Explorer for all folders.[/quote]
I've got it set to "all file system folders (recommended)" and Win-E still launches Opus for me.

Try turning Explorer Replacement off completely, then OK the Preferences dialog. Then open the Preferences dialog again and turn Explorer Replacement back on. That might repair the registry and make Win-E open Opus again.

Also, please check that you don't have any compatibility settings on dopus.exe or dopusrt.exe left over from your Opus 8 install. In particular, make sure Run as Administrator is not ticked for both exes. Having that turned on could break Win-E.


#6

Hmm...curious. I had to switch it to all folders, but now having made that change I can back it down to All File System Folders. Once it has bee set, it does work in any Replacement Mode ON setting.


#7

I've tried all suggestions but with no change.
Neither exe had any compatability settings.


#8

Only thing I can think of to try is this:
[ul][li]Exit Opus.[/li]
[li]Using Explorer, go to C:\Program Files\GPSoftware\Directory Opus[/li]
[li]Right-click dopus.exe and choose Run as Administrator. This will run it, just this once, with full admin rights.[/li]
[li]Open Preferences in Opus, turn off Explorer replacement, then OK Preferences.[/li]
[li]Opus Preferneces again, turn Explorer replacement back on, then OK again.[/li]
[li]Exit Opus.[/li]
[li]Start Opus again normally (not as admin).[/li][/ul]
If that fixes the Win-E shortcut then there must be a registry value that Opus is failing to write due to UAC. I have run Opus as admin once or twice in the past so this may explain why it works for me.

If it does fix it let us know and I'll make sure the problem is fixed.

Of course, it's possible there isn't a problem here at all and something else is the cause.


#9

Thanks for your help but Windows-E still brings up explorer


#10

If you show the Computer icon on your desktop, then right-click it, does it have the Open in Directory Opus option? Is it the default option (in bold)?


#11

Yes and Yes


#12

I'm stumped, sorry. I don't know why it doesn't work for you. :frowning:

It might be worth contacting GPSoft to see if they have any ideas.


#13

I had some problem in Windows 7, 64 bit, but noticed that a reboot fixed it all.