GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Zip issues

First, kudos on fixing the double progress bar bug I've battled this one for ages. :smiley:

I seem to have three nagging issues with zip handling:

  1. Since the newest version, right-click menu for zip files on desktop with dopus never shows up (works fine on regular desktop).

  2. With Opus as "system default handler for ZIP files" turned OFF, double clicking on Zip files still opens them in the lister, rather than launching the default handler (WinRAR, in my case). Even after 'Activate Opus zip handling' is OFF, double clicking on zip files opens them in the lister.

  3. Is there anyway for zip and rar files (with the RAR plugin) to show up as folders in the tree, yet opened by separate application (WinRar) when double-clicked?

Have you rebooted since updating?

You probably just need to tell the program you do want to re-associate itself with the Zip filetype.

Or do you mean when double-clicking zip files within Opus file displays? If you want Zip handling enabled, but want double-clicks on Zips to open them in something else, even when you double-click them within Opus itself, then I think you need to do this:

Go to Settings -> File Types, edit the Zip file type and delete the Left double-click Event. (Normally the event runs the "Go" command.)

Having them shown in the tree doesn't affect what happens when they are double-clicked, so yes. Fix 2 and you should get this as well.

(I assume you mean when they are double-clicked outside of Opus or in the file display, not double-clicking them in the folder tree.)

Yes, many times. I've investigated this a bit more, and it seems that I can repro it on 2 XP-32bit computers with latest version in addition to v9.1.1.7.3307 x64 on Server 2003. (I just didn't notice it until recently) . To reproduce, I just copy any zip to the desktop. Then try to right-click on the zip in the opus file list, but no context menu shows up.

[quote="leo"]Or do you mean when double-clicking zip files within Opus file displays? If you want Zip handling enabled, but want double-clicks on Zips to open them in something else, even when you double-click them within Opus itself, then I think you need to do this:

Go to Settings -> File Types, edit the Zip file type and delete the Left double-click Event. (Normally the event runs the "Go" command.)[/quote]
I got excited when I read your post, since this is exactly what I'd like: to double-click a zip/rar in the Opus File List, but have it opened in the default handler (yet keep zip integration turned on so they show up as folders in the tree). Removing the 'go' command makes sense - I didn't realize this was how the behavior was specified.

However, deleting the 'go' command for the left double-click event for Zip files did nothing differently. I then completely shut down DOpus, and restarted it, but the 'go' command is magically re-inserted for the Zip file type. :frowning:

If you get no context menu at all for zip files then try going through the steps in this FAQ to see if a shell extension is breaking it:

Crash, exit or high CPU usage when right-clicking certain files

You need to fix what happens when you double-click Zip files outside of Opus first. i.e. Make WinRAR (or whatever you want) take over the file type. When you double-click something in Opus, and the Left Double-Click event is not overridden, then the result should be the same as double-clicking something outside of Opus. If the result is wrong outside then it'll be wrong inside as well.

Hmm, that could be a problem. :frowning: Perhaps Opus needs an advanced "don't repair Zip filetypes" setting to prevent this. What it does makes sense in most cases (if you want Opus to handle zips at all then you probably want double-clicks on them within Opus to open them in Opus) but it should be possible to override it.