GP SoftwareTwitter
Opus FAQsManualCommandsObjects

12.19.3 & 12.19.4 (beta) : Check for update fails

Hello,

Check for update fails with error 140770FC:SSL23_GET_SERVER_HELLO:unknown protocol

I don't use a proxy.

See the attached screenshot
image

It's working OK here.

Are you using any firewall or antivirus software that might intercept HTTPS traffic? Some antivirus does by default, for example.

Which part of the world are you in?

Greece, Europe.

I have avast antivirus installed but with it disabled I still get the error. I haven't that problem in 12.19.1

A lot of antivirus still intercepts things even when disabled. Avast almost certainly intercepts HTTPs traffic (which is almost all the traffic these days) as they were recently caught selling people's browsing history to other companies.

Might be worth a try to remove Avast completely, if you're willing to.

That said, we still don't have any similar reports, and there are probably a lot of other people using Avast, so it may be caused by something else.

Hello,

I really think that is not the antivirus. I googled around SSL: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol and all the sources point either to proxy configuration (I don't use any) or to httpd server configuration

See https://knowledge.digicert.com/solution/SO16902.html

It shouldn't be a server issue since that's working OK for other people.

As to proxies, it's possible your ISP is proxying your web traffic, but a lot of antivirus acts as a proxy as well (unless told not to). We can't see what your network setup is though.

It's not a serious issue to sweat about, I could always check this forum and the network functionality I really care about (FTP/Network Shares) work without any issues.

Please note however:

  • I have other applications installed whose "check for update" functionality use calls over HTTPS (eg UltraEdit) that work like expected.
  • I had not such problems with 12.19.1 and 12.19.2

Not completely true, try adding "avast" into the query and you get things like this popping up:

I found if I have Avast running with mail shield enabled I get this error in the Stunnel log window: >> SSL_connect: 140770FC: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

The update checker does two things. It connects to our own server (www.gpsoft.com.au) to actually do the update check (what's the latest version). It also connects to the RSS feed for our blog (blog.dopus.com) to return the list of news articles.

We switched to checking www.gpsoft.com.au over https back in version 12.7.something (over a year ago).

In 12.19.3 we changed the second part, the blog.dopus.com check, to also use https. But the update check part (www.gpsoft.com.au) didn't change at all - since that was already https and had been for some time.

Can you remember - prior to 12.19.3 did you actually get notified of new versions by the "first part" (the line in the screenshot that says "Your version is current") - or were you just seeing them in the list of news articles below?

If you were getting notified through the www.gpsoft.com.au check then it would be strange if that had suddenly stopped working since nothing about that changed.

If however you never got notified there, and were only seeing the new versions announced via the news feed, then this suggests that the https checks have never been working for you, but because the blog was over http until recently that was working and so you didn't realise something was broken.

1 Like

I got the update notification to 12.19.3 on the "check for updates". After that it stopped working, but as I wrote I don't consider it something serious, checking the forum periodically will suffice.

If you have a spare 10 minutes it would be interesting to know if uninstalling Avast fixes the problem. If you're too busy and happy to put up with this never working again then that's up to you!

I will install dopus trial on another computer in my home network that hasn't avast installed and I 'll get back with the results in the following days.

Well, I installed dopus to a laptop (windows 10, 1909) without AVAST

I get the RSS feed however I also get and error as you can see at the image below:

image

Thanks for trying it, although that's 12.19 (which you said worked), not 12.19.3 or 12.19.4. In that version the news feed is not coming over https.

The error that the SSL library could not be opened is strange. If you look in the program folder, are libeay32.dll and ssleay32.dll present?

I will install the latest version when I return to home (late evening) and I will check for the presence of these two files you mentioned.

1 Like