12 Beta Couple Of Bugs

Trying out the rating system, I clicked on a folder, on the ratings column to add a rating, and got a 'used by another program' pop up.

This is a folder that is monitored for changes by Google Drive. It syncs with the Drive cloud.
Putting ratings on the other folders worked fine.

And trying to delete out some ratings in the metadata box; Clicking on the next arrow didn't go to the next folder. The source lister was sorted by 'ratings' descending.
Wouldn't Move

In my title I meant 13 Beta.

After moving out of the selection of that folder, and having to turn off the metadata pane 'auto apply', I got the pop up again, and aborted, but the image of the ratings stars remains, despite aborting adding them. Also note the little green icon indicating Google Drive sync.
Still There

Then after telling me the changes were discarded, but the image was present, the folder also was registered in the 'ratings' column as having a rating. I couldn't get rid of this rating until I quit Google Drive, then the problem disappeared.

After exiting Google Drive to get rid of my rating, then booting Drive again, it lost the icon.
Closing the OP13 window then opening a new one, it appeared again.
Icon Gone
Icon Back


Re Google Drive and metadata, those are likely shortcomings of Google Drive, which has a very incomplete (and buggy) filesystem implementation. Cloud storage in general also will not sync NTFS ADS metadata, so applying ratings to files/folders under cloud storage will only affect the local copies, at best (except for formats where the ratings can be added inside the files, e.g. JPG has a way to store ratings so it's stored in the file instead of next to the file as NTFS ADS metadata).

1 Like

I see.
Looking at what I back up to Google Drive, and it's all documents and pictures.
So I can keep this cloud flaw in mind with how I use Opus. Music is what I would want metadata to sync, but I don't back that up to the cloud anyway. For documents and pictures I can just use the Opus metadata editing for the lister columns for easy sorting and personal notes.

The Google Drive app has a 'pause syncing' option. This makes the locked issue disappear, and keeps the G drive mounted. But I don't see a hotkey to toggle that, so that's a problem. They probably don't want people using the pause sync often.

I wonder if I could somehow force Drive sync pause when using Opus, or in certain folders or something. Or create a new button that has a script that toggles numbing sync. When Drive resumes syncing it shadows me (syncs); everything I changed in those folders, so I won't lose any work, no matter how long it was un-synced for.

Or maybe I'll just try your 'temp file' solution for this issue too. Forgot to even try that.

So the moment a file is modified, Google Drive jumps in, locks the file, then syncs the change?

That seems like a very bad design to me. It should be waiting a moment, and ideally would upload changes transparently without blocking access to files it isn't changing.

Not that either of us can do anything about Google's code. :slight_smile: It's just disappointing if it's written that way.


Yes. By the time I snip a pic and attach it to a post, it's already been synced. It gives you status icons that update in real time. Here's an example of happily synced files (green checkmark) and one that is in the process of syncing. I was quick enough to capture it this time.

I think their strategy is because of Google Photos, and that so many people take selfies etc. In this tiktok era, using filters on their phones to modify pics. So Google's file transfer setup (may be) optimized for media, which has larger files sizes, which take longer to send/receive. Google needs to keep their reputation with Chrome being the fastest browser in the land. Which was their whole marketing scheme to take market share away from Microsoft. So they probably take every little shortcut and trick to make sure it's as fast as possible. If that includes screwing other companies, all is fair in love and brostep.

I thought about the preview viewer (create temp file for modifying) solution.
I did a test, putting a rich text document into one of my synced folders and renamed it, while Drive was running. Surprisingly it worked. I guess Opus gets access to the temp file before Drive tries to sync that one too. I'm thinking I may setup all my files that are synced to make temp files (I've since lost our previous conversation though, and how to do it).

The issue with the Drive icons superimposed on synced folders/files, is they disappear when you eject the drive (quit) or pause it. So I thought to make path level colours and created an icon as a permanent reminder helper. Might do green backgrounds within synced folders too, but that might be too much. The Drive icon might be enough.

I turned this option off.

Then I renamed a pdf that is in a synced folder. I didn't get an error pop up. It did rename without issue.
Oddly the little Drive icon went from synced to the blue syncing icon. (Opus isn't supposed to watch that when the option is disabled). But it didn't go back to the green checkmark. I had to refresh the folder and it did go back (Which is what it's supposed to do with the option disabled).

I tried it again with the option enabled. Same behavior. I didn't get an error pop up, and it showed the blue syncing, but didn't change back to synced when it was done. So it looks like this option isn't doing anything.

Not sure why pdf's aren't causing me the 'used by another program' issue here, or it's possible that my original issue wasn't a permanent problem.

I'm having this issue again. This time it's editing metadata in audio samples that are not synced with Google Drive.
Another Process

Also been having an issue where it is telling me I don't have the privilege to do something.
Required Priviledge

For the used by another process, it was the preview window again. I might just use the 'temp file on edit' for all files that can be previewed.

For the privilege error, I followed a tutorial. My C drive properties "share" permissions was read only. I changed it to full access. Not sure yet if that's going to fix it and/or make me vulnerable to remote assistance access attacks or not.

When the preview window is closed I can edit metadata with either method. There is no pop up errors.
When it's open I can edit metadata in the pane, but not using the Ctrl + M window.

Same with the ratings button, or clicking on ratings in columns. That won't work for me.
But editing ratings in the metadata pane does work.


I'm telling you this to help you isolate variables.
As this is the only program where I have this issue, so that tells me this program is the issue.

Which other programs even let you do all the same actions?

You only see these problems with Google Drive, correct? Opus works OK in other folders. So by that same logic, Google Drive is where the fault is. (Which would not be the first time. Google Drive File Stream is a very nonstandard filesystem with a lot of issues, in our experience since it was released.)

1 Like

Sorry, I don't mean to be so much of a handful.
I did mention that it is happening with my pictures too, which are not synced with Google Drive.
The behavior is different, according to if the preview pane is opened or closed, and if I use the metadata pane, or use Ctrl + M to edit metadata.

I have been working on this problem myself full time, and have made changes, and am still working on it. Recently I wasn't able to add a favorite folder to Listary, because it was open in Opus.

I may have found the offender. A new Google Drive feature.

I remember now when going to Drive on the web recently it's been giving me this new popup notification that there are new 'offline' settings. I just kept dismissing them because it's annoying. No idea how that would benefit me. So I just disabled it now.

Have been checking around Opus to see, and I'm now able to make changes to all my synced files and also the not synced files. Things that I wasn't able to do previously, without permission errors. And now when I 'refresh' the lister those little Drive sync icons refresh to their correct state.

Think I just fixed it. :slightly_smiling_face: Fingers crossed.

A bit of info I just realized, you might want to know.
In some of the folders that sync with Google Drive, there are hidden 'temp' folders.
I'm not seeing these temp folders in every parent folder that are synced.

Drive Temp

So Google Drive might do that same method you referenced earlier; making temp copies of something when it uploads or downloads to and from my hard disk. I don't know how this new 'offline' setting affected this.