2 drive letters showing for the same DVD drive

I have 2 different drive letters showing up for the same & only DVD drive in my system. Big question is why and how do I get rid of the drive I: ?

I did use Administrative tools\disk management to change the drive letter of my DVD drive & then this started showing up.

If I click on 1 of them to open it, with media inserted, it opens just fine.
If I click on the other I get the messae "there's no disk in drive I:" yada, yada.....

I'm running under Win 7 64bit with the latest Dopus 64bit installed

See the attachment for further clarification.

Can anybody help??

Much appreciated if you can. Thanks, Jim

The same appears in Explorer presumably? (Unless it's hiding it since it's empty. But the drive letter is there for everything, I would've thought.)

You are correct. The same exact thing shows up in explorer.

I found this on Google: Same hard drive now showing with two drive letters

Leo, Thanks for the effort, but I also found that on Google & tried it with no success.

I do appreciate your reply though. If you happen to see anything else please do let me know. I've Googled till I'm all Googled out. :>) I even opened up my machine disconected the cables from the DVD drive, powered back up, powered back down, reconnected the cables & powered back up to let Win 7 rediscover the hardware to no avail. Dopus & Win Explorer still report a 2nd drive letter.

Have you tried assigning the letter back to what it was? Does only one appear then? If so, I wonder if changing it again after that might work?

Might also be worth seeing if there are multiple entries for the drive under Device Manager (DVD/CD-ROM drives section).

Can't think of anything else though, sorry.

You could try this (not sure if it works and I didn't test it):

Open the Device Manager (a Control Panel applet): C:\Windows\System32\devmgmt.msc
In the Device Manager, expand DVD/CD-ROM drives, right-click the DVD device, and then click Uninstall.
Restart your Computer and install the drive again.

Yes. I have tried assigning the drive letter back to what it originally was and that didn't help either. One thing I have just narrowed down though. When the system boot up and I look at things with Dopus evrything looks normal. Only 1 dvd drive is listed in my folder tree just as you would expect. I can put a DVD/CD in the drive & look at it's content. So far, So good, no extra drive showing up yet. Now as soon as I right click on that drive, lets say look at it's properies, Bingo!!! Up pops the other drive letter. You can't actually use that "new" drive. Even with media in the drive if you try to use it by clicking on it, it tells you to insert a disk even though there's a disk in the drive.

Things like this just drive me crazy Leo!!! It's not a show stopper, but it shouldn't be doing this!!! :>) :>)!!!

Thanks again & have a great day!!!!

Just an idea. Have you installed any virtual drive programs - Ultra ISO for example ? It could be they're adding a virtual CD/DVD drive at startup with no .iso mounted.

Thank you Steve. Your the winner!! I do have PowerIso installed & it was set for 1 virtual drive so I dsabled it & Whala!! No mor extra drive.

What I don't understand that you might know, is that PowerIso isn't even running, nor did I see any services running that looked like the were associated with PowerISO. So whats getting executed that caues this to happen?

Thanks, Jim

No idea sorry. :slight_smile: