2 prblms: right-click doesn't work; folders open in new tab


Maybe I should have posted 2 different topics, only that these 2 occur always simultaneously, so it might be better to discuss both at the same time:

  1. right-clicking anywhere in the lister area (where you see the files) doesn't bring the context menu (as if right-click was disabled). right-clicking on a folder in the folder tree area does seem to work, though.
  2. double-clicking on a folder (in the lister area) forces the folder to open in a new tab, instead of opening in the same tab.

Thank you for any help

Ps: Restarting the PC seems to work (for a while), and then the problems come back again

Right off the top of my head I can't think of what might cause the right click problem unless of course you've tweaked the customize/context menu settings to a point where they won't work. You might try resetting them to the defaults and see if that makes a difference.

On the second issue (which you should only post one issue per thread as requested by the moderators), make sure your SETTINGS/FILE TYPES/ALL FOLDERS events settings are configured for left double-click as highlighted below in my screen grab. Sounds like your left double-click event is set to GO NEWTAB instead of just GO.

Thank you for your reply.

I never tweaked any of these configurations. The strange thing is, that after I restart the PC, everything seems to work normally again (proving the problem is not related to the settings). Then after a while the anomalies start over.
While this strange behavior occurs, right-clicking in the windows explorer file browser works fine :frowning:

Even ending the processes dopus.exe and dopusrt.exe, and then restarting dopus, dont fix these 2 problems.

Do you mean right-clicking on files & folders within the file display (right-hand pane), or do you mean the menu that appears when you right-click an empty space within the file display?

When you test with Windows Explorer, are you right-clicking on the same things as in Opus?

It sounds like the kind of problem that a context menu shell extension could be causing. The steps in this FAQ may help you narrow down which extension is going wrong, if that is the case.

Hey Leo,
Thanks for trying to help :slight_smile:

A few points:

  1. Both right-clicking on files & folders and also on the empty space produces no result.
  2. I can still point (select) files using the right-click as if it was the left-click (including double right-clicking to run files).
  3. I tested in Windows Explorer on the same things as in Opus.
  4. No extension apparantly is going wrong. Debugger shows nothing (Opus doesn't crash or report an error).
  5. Double-clicking on a folder forces it to open in a new tab instead of same.
  6. These 2 problems don't happen in views other than details view! (including power view). List, thumbnails etc. all work fine! When I switch back to details, the 2 problems re-occur.

I really love this superb piece of software, and wish it could perform as it did before.

Thanks again

Try the steps in the Finding The Culprit section of the FAQ I mentioned. Does anything appear at all in DebugView when you right-click things?

I have already tried to "find the culprit", with no success.
Right-clicking produces nothing in the debugger.


Yet it works in other modes? That's completely bizarre. If it works in Details but not Power then that's easily solved as it would be the mouse button configuration, but it being the other way around makes no sense as there's no mouse button configuration for Details mode.

If you use the other modes for long enough do their menus stop working after a while as well?

You may need to contact GPSoftware for support as I'm out of ideas and nobody else on the forums has come up with anything or said they've seen the same thing so there's not much more we can do.

These things will all happen on a normal system if you have the ALT key held down. Next time it happens, try pressing the ALT key by itself a few times - maybe it's just stuck down or something?

Oh well...

I can make a wild guess, that it has to do with the registry or something. The funny thing is, that whenever I restart the PC everything works fine again, so I don't think its Opus' fault.

Maybe the next release will come up with a solution (although the same problem used to happen with Opus 8 as well).

Thank you for trying to help. :slight_smile:

I've seen Windows think my Alt or Control or Shift keys are held down sometimes when my keyboard/mouse drivers get confused.

(I've got shift, ctrl-f4 and alt-f4 bound to mouse buttons and sometimes the drivers don't send the "button up" message.)

Jon's suggestion of pushing Alt down and then up next time the problem occurs is definitely worth a try. doing that will reset Windows' view of the key.

Yes, maybe just changing the version number will somehow resolve the problem. :slight_smile: