3.6g+ memory usage (possibly tied to BitDefender?)

Noticed my system was running a tad slow.
Checked this out and found it was taking up lots of memory.
Over 3.6gig.

Is there anything I can check?
Let me know what else you may need.

ps. I'd attach a pic but not sure how. :frowning:

Drag images on to the post editor to attach them.

Was it dopus.exe using the memory, or something else?

Does the memory usage go down when you close all Opus windows which are open, or does it remain?

ok thanks.
memory usage stays when all opus windows are closed.

Looks like a leak, but it may be caused by a shell extension rather than Opus itself.

The first thing to do is to track down how to trigger the leak on your system.

Sometimes leaks will be caused by some of these things:

  • Going into a certain folder.
  • Going into folders with certain file types (or with a particular file that triggers the problem).
  • Right-clicking certain files or file types.

If you can work out which file or folder triggers things, we can then suggest things to try to see if it is Opus or a particular shell extension causing the problem.

It's also possible to use VMMap to track the leak to a particular component, but some people have found it doesn't work great on newer versions of Windows. (Windows 10 at least. Not sure if anyone had problems with Windows 8, which it looks like you're using from the screenshot.) That's detailed here if you want to try it: How to find components causing memory leaks.

Also: Which version of Opus are you using?

ver: 12.0

Sounds about right. I just noticed one other time, but dismissed it, about a week ago.
I'll see what I can find out.
Thanks for the link.

I have a lot of directory junctions I've created. Opus doesn't follow those ad infinitum , does it?
I've tried my best to avoid circular references with them.
...just a thought.

If you're on 12.0 and not 12.6, updating to the current version is worth it just to rule that out.

Opus itself won't have a problem with them. A shell extension could in theory, but it's unlikely it would cause a memory leak if one did.

Correction...I'm on 12.6.2

I ran vmap. Two things I noticed.

  1. dopus.exe (in Task manager|Details tab) keeps climbing ~44k per second continuously.
  2. vmap crashed (maxed my memory) before I could get to see what was loading it.

When vmap crashed dopus.exe was only at ~89k. I will let it run and see how long it takes to max out.

So I turned off BitDefender and now it looks like dopus.exe is stable.
How can that program affect yours?

Try turning BitDefender back on, but disabling any shell extensions it installs, which you can see using ShellExView, then reboot.

If the leak remains gone, it means BitDefender is probably installing a shell extension with a really bad memory leak.

If it comes back with the shell extensions removed, but BitDefender itself enabled, it might mean there is a memory leak in their virus scanning routines.

Both aspects of BitDefender can affect other processes, since their components are injected into dopus.exe (and many/most other processes) and they can run whatever code they want within those processes.

Whichever cause you find, if it definitely looks like BitDefender then it needs to be reported to them so they can fix it. Narrowing it down to the antivirus itself or the shell extension should help them a lot. If it's triggered by a particular file or folder then that should also make things easier for them to find and fix (especially if it turns out the same is true in Explorer), but they can ask for whatever information they need to reproduce what you're seeing.

Thank you .

First and foremost...
Thank you for taking the time to reply in such a quick manner. I can only imagine you
probably have tens if not hundreds of questions to reply to weekly.
I do appreciate your help.

...moving on....

Unfortunately, BitDefender doesn't have a very useful interface. Meaning, there is no single off button.
( At least I cannot find one :roll_eyes: )
I toggled off then back on all the features (in yellow).
Seems to have done the trick. What exactly fixed it??
Not sure, but it's a small effort for me to remedy it in
this manner until they realize they have a leak and get it


I had a similar problem. Opus using 100 per cent of processor and crippling the machine.

I found by setting Bitdefender not to check the Opus Thumbnail Cache folder cured the issue. I am assuming Opus must update the cache from time to time and that is when the problem happened.

Did you let the BitDefender developers know?

Just waiting a few days to make sure this is a fix and then I will let them know.