7zip plugin failing

There seems to be a problem with the 7z VFS Plugin.
when i try to open a 7z file i get the error (see Screenshot):

... The Archive appears to be invalid or damaged
7zFM can open it.
My VFSPlugins folder contains these 2 files only :

opus7zip.dll 7z.dll

I have another Question:
How can i change the "Add to Archive" to automaticcally select "Archive Type" 7z and "Compression level" Good as default, so i don't have to select then every time i create an archive.
Thank you.

Have you tried any other 7z files?

Does this one work?

test.7z (65.7 KB)

Yes, i tried several files. Your file produces the same error.

Does 7z appear in the list of archive plugins in Preferences?

If it does, does clicking Configure on it work?

Does creating new 7z archives in Opus work?

With an existing atchive, have you tried selecting it via the tree in case something's up with the double-click action?

Yes, attached Screenshot shows Details
Yes, this is the most strange thing for me. I can open the Opus-created 7z with 7zfm, but not Opus.
Archives appear in Tree, but clicking there produces the same error

Have you tried disabling any antivirus or 'zone-alarm' type program.

Yes, Symantec Endpoint Protection has been disabled for a test and still not working. Am i the only one with this issue?

Are you sure the old 7zvfs plugin isn't in the VFSPlugins dir? Maybe you looked under x86 instead of the main dir?

From the date on the plugin, you're using the initial release. Later versions ignore the plugin which causes the conflict. Try downloading again, or beta if you prefer to try the even newer version.

I installed beta -was still not working initialy.
But i got it to work this way (this was not woking on
[li]Disabling the plugin[/li]
[li]shuting Dopus down[/li]
[li]enabling the plugin[/li][/ul]
Thank you!

A couple of people had this problem due to (for some reason) having .rar included in the list of zip extensions in the Zip preferences page, which made Opus try to open the archives as Zip instead of what they really are.