9.1 hangs on Vista when browsing a DVD

I just got Vista (I know...I should have waited for sp1) and Directory Opus 9.1 hangs it.

I get a (Not Responding) for it but I can't get into the task manager to close it. It prevents me from shutting down and/or logging off too.

Basically, i have to power cycle my notebook after running it. This happened when i tried to access the DVD drive.

Any settings I need to change for DO 9.1?



Have you tried doing the same thing in Explorer in case it isn't Opus?

If it only happens when using Opus then it's possible that the problem is caused by certain files or types of files on the DVD you're browsing either crashing an Opus plugin or a shell extension.

In that case, try following the troubleshooting steps in this FAQ:

Crash, exit or high CPU usage when viewing certain directories

It's definitely not normal for browsing a DVD, on Vista or otherwise, to cause Opus to stop responding. I've been using Opus on Vista for a year now without ever seeing that.

The first time i copied some files from the DVD and the second time I double-clicked on an .exe off the DVD and then DO went into orbit. I just used explorer and it was fine. As long as i know not to use DO on the DVD, i'm fine. I'll try to narrow it down as things happen.



DO 9.0 just crashed on my xp box accessing the CD drive...I have not tried the latest which may have this problem fixed...

Doesn't seem like it's windows version specific...oh well...


One of the recent updates had a fix in it for crashes when CDs/DVDs were ejected, which might be related to your crash so if you're using 9.0 (why?) then the update might solve the problem.