A couple of weird glitches on Jp WinXP

Sorry for the abstract title but lately I had a couple of small and weird glitches popping up that weren't really worth of their threads individually, so let's see whether it's something I'm doing wrong here before asking about each one of them and carpet bombing the forum :o)

So after installing Opus on my new comp I noticed there are a few glitches that prevent normal work.

  1. I can't use some of the view modes - they're greyed out. I'm sure they weren't on my old comp and in fact I have no idea how would I grey them out even if I wanted to. (attachment 1)

  2. If I select a .rar file and it shows in the preview pane, I can't delete it if it's bigger than cca 2000kb. I get the following error (attachment 2) saying something along the lines of "the file is in use". The file can be deleted by either configuring the Text viewer plugin to disable the hex mode or close the viewer pane which makes the rar deletable again. Maybe there are problems with other filetypes, I don't know, I noticed it while working with .rars.

  3. There are a few empty folders that I just can't delete no matter what. I tried restarting the comp, restarting Opus, turning all the plugins off, deleting the folders as soon as the computer starts... no luck. Similarly I get the generic "is in use" message when I try to delete them (attachment 3). Weird thing is, it's just certain empty folders.

For the problem 2, so far I tried disabling the .rar plugin, deleting the unrar.dll in the system32, renaming the files and some other shots in the dark that didn't really help so yeah... For the 1 and 3 I have no idea what to do.





Edit: oops, the attachments are in the reverse order... sorry...

Problem 3: Try Unlocker: ccollomb.free.fr/unlocker/

Christiaan: Unlocker... ok that solves it. Thanks!

Firefox is\was the culprit - the confusion came from the fact that the only new thing installed was DOpus and this particular machine never had any problems like this before; but apparently Firefox was putting new builds in too, which are causing tons of problems on my comp.

Well being the file manager Opus is the first to arise suspicion despite the fact it's one of the best pieces of software I use in my daily work- sorry about this.

Forcing Handles Closed. Why forcing a handle closed is another name for "corrupt my hard drive".

Better to work out what's locking the file/folder (Process Explorer is a good tool for that) and exit it, or use a tool which can delete the file/folder on reboot.

I didn't understand a word of that article but I get it's bad, evil and wrong - let's hope nothing got corrupted since I just opened the window, saw Firefox listed there and then went to task manager to kill it (although it got stuck and didn't want to die etc but that's another story).

Uninstalling it right away.

I have Unlocker installed for 3 years now and I only used it 3 times (I think). Never had any problems or data loss ...
But it's a very good article. Thanks Leo! :wink:

@ RayMarble: It's not that bad. :wink: It is recommended to Unlock wisely and to close open processes locking files or folders.
Simply right click the file or folder and select Unlocker. If the file or folder is locked then a window will
appear with a list of processes locking the file or folder. Unlocker doesn't just delete the file / folder!

Yes, that's how I did it (right clicked on the folder, saw the process, exited, went to task manager etc) - so this part of the problem is solved! :slight_smile:

The unavailable view modes are probably because you are in a system folder like the desktop that doesn't support these modes.

That must have been it, wasn't aware those modes are unavailable for desktop. I never visited my desktop through Opus on my old comp so wasn't even aware of this. Good to know! Thanks for clearing that up jon.