A curious problem with context menus

Hi all...

I use a program called Revo Uninstaller Pro for my software installations and removal.

It used to have a file context menu item "Install with Revo Uninstaller Pro" (this allows Revo to record all changes made by a software installation.)

Now this worked perfectly before I had to re-install Windows yet again. Now, the context menu refuses to appear in Dopus yet it IS present in Windows Explorer and works perfectly.

This is rather baffling...

I have re-installed both Dopus and Revo - but still the same result.

Anyone have any suggestions?



Go to Preferences - Advanced - ignore_context_menus and make sure it is clear.

Besides that, I'm sure Leo has mentioned that he has blocked a lot of context item menus because they have bugs. Your version might be one that is is now blocked in whatever version of DOpus you use now vs whatever version you used before reinstalling Windows.

To confirm this hypothesis, find the GUID of the Revo context menu and add it to the allow_context_menus on the same page.

If you need help finding the GUID let me know, but it's in the Directory Opus documentation.

No Revo components are blocked default.

The list of shell extensions which are blocked by default is here:

Hi guys...!

Thanks for the responses...

I've checked the " ignore_context_menus" and it IS clear (as is allow_context_menus). Using a context menu manager (Yamicsoft Windows 10 Manager) Revo is not mentioned as a "file" menu but is there as a "folder" menu item which appears to be for uninstalling a program in that folder.

I do need help with finding the GUID... Please? :slight_smile:

The manual refers to "context_menu_debug" and then to the FAQ. I can't find a reference in the FAQ...



Here's the FAQ:

The debug steps in that can tell you if the Revo shell extension is being tried (and just not returning any menu items) or if it isn't being tried at all for some reason.

It also links to a tool called ShellExView which can be used to see which shell extensions are on the system, look up their GUIDs, enable/disable them, and so on.

A couple of things: Make sure you are not running the whole Opus process elevated as admin. (Admin Mode to elevate individual windows is fine, but don't run dopus.exe itself elevated.) And reinstalling Revo Installer may be worth a try to see if it repairs things.

As a more general note, we do not recommend using special uninstallers with Opus. Opus's uninstaller does everything that should be needed itself, and any 3rd party tool that tries to second-guess things is more likely to cause a problem than improve things, in our experience.


The problem gets to be even more interesting... Not to mention baffling...

The "Install with Revo Uninstaller Pro" context does not work on .exe files but it DOES appear on .msi files in Dopus (and Explorer).

Why it works on .exe files in Explorer but not in Dopus is a mystery...



Fixed the problem!

I wiped Windows 10 completely, deleted the partitions on C: and re-installed Windows. The main reason was that other things were going belly-up including Windows repeatedly forgetting my default programs for files...

Now everything works normally (including the context menus)!

Obviously when Windows installed itself the first time (this week) it screwed up (or at least one of the updates failed...)! (Thanks again Bill!)

Thanks for the assist anyway mate... :):grinning: