Accelerator ampersand is displayed by Go TabGroupList

Not a bug, but an inelegance. I tried using the usual & as a keyboard accelerator in the tabgroup names displayed by the command Go TabGroupList Icons. It works perfectly, and I am finding this approach more convenient than the suggested command Go TabGroupList Keys,Icons where the numbers are hard to remember, there are only 10 of them, and they change every time a new tabgroup is added.

The inelegance is that the ampersands are displayed in the list, as in the image below (and when the keyboard is used, the letters are not underlined, even though the key activates the button). This doesn't happen elsewhere in DOpus.

The & characters are just & characters there. They aren't doing anything, except putting & characters in the labels.

You should find everything works exactly the same if you remove those characters from the labels. The first letter in each label (skipping symbols like &) automatically works to select its menu item via the keyboard.

(We also wouldn't want to change the menu to interpret & characters, because it'd mess up people's existing group names that might use them as normal characters.)

Leo, that's not how things seem to be working on my system, but I am probably misunderstanding something.

  • If I change &T. TeXMacros to T. Te&XMacros, then pressing X brings up the tabgroup, and pressing T does nothing.

  • If I omit the ampersand completely, changing &T. TeXMacros to T. TeXMacros, then pressing T still does nothing.

  • If I use the ampersand before space, changing &T. TeXMacros to T. TeX & Macros, then pressing Space brings up the tabgoup, but pressing T does nothing.

That is, & seems to be working as an accelerator key, but it is being displayed in the names in the tabgroup list. The first letter seems to be irrelevant.

Pressing T works here, with no & at all in the group's name.

This is with the list you get via right clicking an existing tab. The list in the toolbar menus may behave differently; I haven't tried that yet.

It's always trickier than it looks. At the moment, one of my tabgroups is temporarily named T. Te&XMacros.

  • When I access my tabgroup list via the button Go TabGroupList Icons, the ampersanded key X works, but the initial letter T does not work.

  • When I access my tabgroup list via a rightclick on an existing tab, the initial letter T works, but the ampersanded key X does not work.

The initial letter convention seems fine, although I didn't know about, so perhaps the most straightforward resolution is:

  1. Change the behaviour in the tabgroup list obtained via Go TabGroupList Icons so that the initial letter is the accelerator — this will then agree with what happens in the list obtained by rightlicking an existing tab.

  2. Document the initial letter acceleration in the Help file, maybe at Tabs - - > Tab Groups and
    Internal Commands - - > Go - - > TabGroupList - - > Icons.