Access denied moving files to system folders


Like the title says I can't move files fo system folders on a fresh win 10 install, sometimes it displays nothing other times it displays an access denied popup.

It only happens with dopus explorer is ok can you please tell me how to disable this ?

Do you get a UAC prompt? (Is UAC enabled?)

Have you rebooted after installing any Opus updates?

Could your antivirus be blocking Opus but not Explorer from writing to those folders?

was going to add UAC is disabled

no updates win 10 was installed a couple of days ago

I tried with AV disabled, the same

Just noticed that with explorer it requires admin permission but it moves file to sys32 folder when I click ok

I noticed this happening as soon as I installed dopus

I clicked on dopus administrator mode button and was able to move the file to sys folder, how can I make this permanent ?

It sounds like your system's UAC settings are messed up. If UAC is disabled, Explorer would not be asking for permissions. And it seems like Opus can ask when you click the Admin Mode button but not while doing a file copy, if I understand correctly?

I would check the UAC control panel, and also the group policy settings (if you have edited those in the past) to see if they are still how you want them.

Turning UAC on/off, rebooting, and then back to how you want it again, and rebooting again, may reset things.

(Do you mean UAC is fully disabled, or just that it's set to one of the values that doesn't prompt as often in Explorer, for example?)

When I click Opus admin mode button I can copy and it does not ask anything

How can I check group policy settings ?

UAC is fully disabled, will try the enable reboot now

In Windows 10, UAC can only be disabled via group policy settings, so that combination of questions tells me UAC isn't disabled. :smiley: You may just have set UAC to never prompt you, which is different.

What is selected in the main UAC control panel?

Hmm, I see, in UAC never notify is selected

How can I change the policies then ?

Btw I tried enabling UAC rebooting, disabling rebooting still the same

Try setting it to Always Notify so you can see what's going on a bit easier.

If you still get an access denied error when copying certain files to certain places, it may indicate the files are in use, or permissions prevent even an admin account from doing the operation.

When you test in Explorer, are you doing exactly the same operation?

The options under Preferences / File Operations / Copy Attributes can also play a part. For example, if you have Opus set to update permissions when moving files, Explorer doesn't do that, and it's an extra thing which may fail (although it failing would not usually mean the move itself fails, it might with some of the other options there).

PS: If you're using MalwareBytes, see the banner at the top of the forum.

So I reinstalled Opus and now it copies the file into the sys folder without asking but it asks for admin permission to delete it

In explorer now it asks admin permission to copy to or delete, must've made some difference the UAC enable disable reboot thing

Not using malwarebytes, but I have bitdefender installed

But it's ok as it is, I don't mind if it asks for permission would prefer not to but never mind, what bothered me was the access denied.

Thank you