Access denied when moving (copy allowed...)

When I wish to move a folder from one drive to another I very regularly get an "Access denied"-error.

Often a workaround is to first copy the folder and then delete the source folder.

Unlocker tells me there is nothing locking the folder.

Any suggestions ?


[quote="mrwul"]When I wish to move a folder from one drive to another I very regularly get an "Access denied"-error.

Often a workaround is to first copy the folder and then delete the source folder.

Unlocker tells me there is nothing locking the folder.

Any suggestions ?


later, for what's worth ..

ProcMonitor shows:

IRP_MJ_CREATE -----\Device\HarddiskVolume13\JPG\Paragon-----IS DIRECTORY-----Desired Access: Generic Read/Write, Disposition: Open, Options: Sequential Access, Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Write, AllocationSize: n/a

IRP_MJ_CREATE------F:\BestCrypt\PVT\JPG\Paragon-----REPARSE-----Desired Access: Generic Read, Disposition: Open, Options: Sequential Access, Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Write, AllocationSize: n/a, OpenResult:

Problem seems to have some kind relation with Bestcrypt containerfiles.
Also when using standard Windows Explorer I am getting the same error:

  • cannot move a folder to a subfolder on the virtual drive (only copy) - access denied

  • cannot delete a folder, same error, need to use unlocker to delete the folder.

Will contact Bestcrypt.

Bestcrypt has an option, which I think is on by default, to "protect" its container files from accidental deletion. You probably just need to turn that off.

Think you mean 'disable guard utility'.

Noticed however that this is not a Bestcrypt issue, but more an XP problem (Vista seems to have a hotfix for this).

One way or the other it has some relation to mounting drives (network drives?), as subfolders.

When mounting any drive a subfolder (see: I am encountering
the same problems as when mounting a Bestcrypt drive:

a) move a folder from a normal drive to a mounted drive : access denied
note: copy a folder from a normal drive to a mounted drive: is possible

b) delete a folder in the normal way - access denied
need to do "shift-delete" (bypass recycle bin)

c) on a mounted drive I always need to F5-refresh screen after any delete/copy action.

I think this issue is not / will not be solved for XP.... :cry:


Since it happens in Explorer as well, it sounds like the test to work out which logical drive contains the the directory is failing. It must be indicating that the drive with the mount point and the mounted drive are the same when they are obviously not.

That would explain why moving doesn't work: It's trying to move by rename, instead of copy-then-delete, since it thinks things within the mounted folder are on the same drive as those outside of that folder, which isn't really true.

It would also explain why the recycle bin doesn't work: It's trying to move the deleted files within the mounted folder to the recycle bin of the drive that contains the mount, but they're not the same drive so the move fails for the same reasons as above.

Vista did have a lot of improvements for working with junctions so it makes sense that this is handled better on Vista than XP. Shame that MS never released a hotfix for XP's handling.

MS knows about the delete folder in a mounted drive-issue.

The move-issue likely is related to that, as well as the refresh.

The problems donot occurr when mounting Bestcrypt drives as individual drives (with separate drive letters).


I am getting the same problem on my C: drive. My workaround unfortuneately is to use Windows File Explorer! It works fine - so I thnk it is a problem with DO.

Ross, when using drives mounted within folders, or something else?

Are both Explorer and Opus doing the same thing when you drag & drop? (Copy or move etc.)

Does it work if you drag with the right mouse button?

Which version of Windows?

I'm running XP Pro SP3 (32bit). It's odd that I am unable to reproduce now, but I do get the error occasionally. I will try to better diagnose the problem the next time it occurs.

I get this problem using folders on drive C:. I am not using any other sort of drive. I am trying to move Visual Studio C++ project files around.

I don't have anything open that would have a lock on the folder I am moving. Although Symantec Endpoint Protection and TourtoiseSVN are running in the background.

My recycle bin was getting overstuffed and giving me trouble (took 10 minutes to empty), but I don't think that's related.

TourtoiseSVN, as good as it is (I use it too), is widely known for locking random directories for no good reason, at least on some people's systems (mine included). I regularly find I have to kill TSVNCache.exe in task manager to allow folders to be moved or deleted. (Usually ones that have no source code or SVN content in them!)

I don't know if that's the cause, though. If you find things are locked you can often use either of the SysInternals tools handle.exe or Process Explorer to find out which process is locking them.

It's possible Opus itself is locking the files or folders, usually because it's in the middle of getting some data about them. These locks should only be there for a split second normally but sometimes they never get released. In my experience that is almost always caused by video codecs which sometimes fail to release the files which Opus has tried to get information about (e.g. video duration or dimensions). It'll look like dopus.exe holds the lock but it's really the codec's fault. (The codec runs inside of dopus.exe but is a 3rd party component.)

Since you mention TSVN, though, I'd definitely try killing its cache process next time you find you can't move things. It's harmless to kill it and it will restart it when it needs to. I kill it all the time...

Currently mounting drives as a subfolder under Windows XP has more cons than pros. At least, that's the I feel it.

Another issue I came accross is that when checking the size of the mounted drive under XP (RMB properties) it will count the
number of GB's, which will take a while when the drives is e.g. 400 - 500 GB, rather than quickly show the usual pie-chart.

Mounting drives as a normal drive (not as a subfolder) will show the pie-chart.

This seems to have been fixed in Vista, but not (yet) in XP.
With Windows7 coming up, likely this will never be fixed.

All in all, mounting drives as a subfolder under XP, for me, has too many drawbacks and I went back to mounting them as a virtual
drive with their own drive-letter.


Yes, I think I was too quick to dismiss SVN. I just got another access error, and on closer inspection there are some .svn folders buried in the folder I am trying to move. I tried deleting all the pesky .svn folders - and sure enough I got an error on the deletion. I hit retry the delete diaog and it worked on the second try, then I was able to move the parent folder without any problems.

So yes, it looks like TSVNCache is the culprit. Although I don't recall ever having this problem with Explorer. Maybe Explorer has some sort of built-in retry logic that DO doesn't?

Regarding TSVNCache..

you might want to read the "Icon Overlay Settings" paragraph here: ... tings.html

FWIW, I have TSVN set to exclude * and include only the drive I use for source code and I still find TSVNCache.exe sometimes locking random folders, that don't have any relation to SVN, on other drives.

It's worth using the exclusion stuff to speed things up (so it doesn't scan changes to other drives) but I don't know if it will help with the locking issue. I still find I have to kill TSVNCache.exe every so often when I can't delete something.

Have you typed * in the "Exclude paths" textfield or did you uncheck all drive types? Don't know if the first does what we would suppose. Might be worth to try the second.

  • in the Exclude Paths.

I didn't think excluding the drive types would matter due to the description on the TSVN website of how the include/exclude settings works:

if (path is in include list) show overlays if (path is allowed drive type) AND (path is not in exclude list) show overlays
However, I missed this part just below that:

TSVNCache.exe also uses these paths to restrict its scanning. If you want it to look only in particular folders, disable all drive types and include only the folders you specifically want to be scanned. 

So I'll give that a try. Thanks for the suggestion!

4 posts were merged into an existing topic: Problems renaming files and folders (MalwareBytes related)