Add .xpi as a "normal" zipfile

Any ideas how I can add other files to be handeled as normal zip files by dopus? Setting to open this file with eg. WinRAR works, but setting dopus doesn't make dopus open it.
Any ideas?
Thanks, Walser

Have you tried to do a Copy EXTRACT command against these .xpi files? If Dopus cannot extract this file format I'd guess it can't open them as folders either... WinRAR supports more formats than the limited internal archive support offered by Dopus.

Those formats (like .xpi) which are in fact just renamed zip files. Can be handled by Opus easily.

Simply go to:

[i]Preferences - ZIP Files - Settings[\i]

and add the extension to the list at the bottom of this tab. Seperate each extension with a ; (semicolon).

For example my list of extensions is currently:


Also, if the .xpi files are truly just renamed 'standard' zip files and you've already done what Tanis has suggested I just remebered about a bugette that after adding an extension to opus' list of 'zip extensions' you might still need to set the dblclck event for the specific filetype to run the Go command...

No idea what you're talking about Steje. I just set Opus Zip to include xpi files, downloaded one from firefox's extensions site and was immediately able to dbl click it in Opus to view the contents. No further config necessary...

Hmmm... cool!

I poked around and found this thread that talked about it - but then it was 'me' talking about it - LOL - so no help there (consistent in my wrongness?). Maybe the guy with the jar file dblclck issue had a different problem or maybe it was fixed in 8.1... but I definitely remember adding .dps files to the zip extension list and was confused at the time why I wasn't able to 'Go' inside of them - manually setting dblclck to 'Go' made it work though.

Ok, I added these file extensions to the list and now I can open them when I directly type their path into console (the abr that shows the current location.. don't know its name). However, doubleclicking on them does still open winrar. I don't want to make dopus default for zip files since I only use it for decompression - so for zip files "right-click open" opens winrar, doubleclick opens in dopus. For all other extensions double clicking opens in Winrar. Any ideas how that could be automated, or maybe I do have to restart in order to work? (restart dopus, not windows)

So just to clarify because I may have become confused somehow... are you wanting to make sure when you double-click on these other extensions, that Opus opens them in the lister as if they were folders?

If so, then as I mentioned before go into the Dopus file type editor (Settings->File Types...) for these extensions (System File Types->xpi) and make sure the dblclk event (on the Event tab) is set to run the Go command.

I've done some more testing - and like you I added XPI files to the list of extensions handled by Dopus but like Walser this did NOT allow me to double click them to enter as folders - ie. they still opened in PowerArchiver.

What seems to be happening is that if you ALREADY have some specific command or program being called for the dblclk event (in my case "C:\Program Files\PowerArchiver\POWERARC.EXE" "%1"), adding the extension of the file to Dopus 'zip list' will NOT overwrite the existing dblclk event with the required go command. I found that if I deleted the current dblclk event command - thus making it - then adding the extension to Dopus 'zip list' does indeed update the event with the go command. So I guess the 'bugette' that I was referring to is still there (I'm running v8.1.0.8 ANSI) if this can be considered a bug. Keep in mind that the Dopus dblclk event is Dopus specific and does not alter the open action for the file type which would affect the whole system - i.e. Explorer - and which MOST filetypes default to being subjected to when double-clicking on them (with the lack of an explicit dblclk event being defined).

yep, stejes tip finally did it how I want it :slight_smile:
thanks for all your help

Great - and can you say if the detail about the existing dblclk event already being defined was true on your system? You probably had WinRAR.exe specified in there somehow already?