Again protected RAR problem

With newest DO extracting of protected RAR-Archives doesn't work (drag'n'drop). No window appears, nothing happens.

It seems to work okay for me with the 32-bit version at least. (I haven't tried with 64-bit.)

Here are the two test archives I created to test with.

One has encrypted data & filenames (so you have to enter the password as soon as you double-click it) while the other only has encrypted data (so you don't have to enter the password until you drag out of it).

The password for both archives is moo
Kittinger-jump_names.rar (549 KB)
Kittinger-jump_dataonly.rar (549 KB)

BTW, are we talking about opening the Rar in Opus or in WinRAR?

What is the drag & drop event set to in your file types?

Normally All Files & Folders will have drag & drop event of Copy MOVEWHENSAME (or Copy MOVE if you change it like I do, but I've tried with both and it seems okay for me). The separate All Files and All Folders file types should not have any event defined for drag & drop.


I've had this same problem for a while and while it was bugging me a bit I couldn't be ars*d to look into it further :slight_smile:

But now seeing you had the same problem I did, and found the problem very weird as I investigated:

The only drag-n-drops that wouldn't work were the ones when I dragged the file(s) to the same folder that the .RAR-file was in, all other drag-n-drops would work fine.

Anyways, I downloaded an updated version of WinRAR and the problem went away instantly :slight_smile:

I was using "3.80 b[eta]2" before, now it just says 3.80.

A link for your convenience:

Using DO plugin (DO=Left dblclk, WinRar=Middle dblclk).

I tested both archives, all ok. Three protected archives (unfortunately deleted in the meantime) didn't work before, maybe something was wrong and ok again after reboot. I'll report if it happens again and upload the archive then.

Another "mystic": Can't extract folders from RAR's opened in DO-Lister to a path at the top on a lister (see pic). Files can be extracted this way.

Doesn't work with files or folders for me. Also, it does work for both if I drag to the opposite file display border.

I've reported it to GPSoft.

Thanks Leo.