Always pop-up the update dialog

I'm using the Chinese version of DOpus, and since the 11.10 update, my DOpus is always pop-up to notify me that update is downloaded and do you want to install it. but even I install the the update with auto update, or download the installer to do it manually, it stills pops-up this dialog, and It shows my version is 11.8, even I open the exe, in the about screen it shows I'm using 11.8, but if I right click on the dopus.exe and see it's file info says it is version 11.12. Also if I run the installer to update my DOpus, the installer also shows I'm updating 11.12 to 11.12.
What's going on?

Are you definitely running Opus from the dopus.exe and location you're looking at? Maybe two copies are in your machine.

Yes, I found another dopus copy located at C:, but I'm using the one is installed at E:, how could it be? How can I fix this?

For now, even I run the 11.13 version which is located at C:, it still running the version 11.8 one which is from E:\

I reinstalled the dopus after clean uninstalled it. Now it back to work again.