Always Prompted for FTP Password

I believe I am experiencing the same issue as the OP in this thread, the only differences being this has never worked for me (that is; saved the ftp password), and also pressing escape / cancel just takes me back to 'My Computer' rather than connecting to the FTP site.

I have created an FTP address book entry and double checked the password itself as well as the 'ask for password' setting in the global settings and the address book entry.

Here are the logs from when I connect:

Opening Connection 220---------- Welcome to Pure-FTPd [privsep] [TLS] ---------- 220-You are user number 118 of 550 allowed. 220-Local time is now 04:35. Server port: 21. 220-This server supports FXP transfers 220-IPv6 connections are also welcome on this server. 220 You will be disconnected after 15 minutes of inactivity. 331 User <username> OK. Password required 230 OK. Current directory is / 215 UNIX Type: L8 211-Extensions supported: EPRT IDLE MDTM SIZE REST STREAM MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*; MLSD AUTH TLS PBSZ PROT ESTA PASV EPSV SPSV ESTP 211 End. 200 MLST OPTS type;size;sizd;modify;UNIX.mode;UNIX.uid;UNIX.gid;unique; 200 TYPE is now ASCII 257 "/" is your current location 250 OK. Current directory is / 257 "/" is your current location 227 Entering Passive Mode (64,64,131,105,12,253) 150 Accepted data connection 1163 bytes received in 0.265 seconds (3.928 Kbytes/sec) 226-Options: -a -l 226 10 matches total Connection closed

Any ideas?

How are you starting the connection to the site?

Which line in the log is the last one printed at the time that you get prompted for the password?

Either by typing the address into the 'Go:' bar, or by using a 'network location' saved in 'My Computer'. Sorry, didn't actually try connecting directly via the address book entry; it works fine. However, I want to be able to connect via the other 2 methods without having to enter a password.

I can't see which line is the last one printed before getting the password prompt as there doesn't seem to be anything logged until the connection is complete.

I don't think either of those use the address book at all, so they won't use a password stored in the address book. There's no way around that, I'm afraid.

(You can include the username and password in the URL you type into the address bar, but that wouldn't really save you any typing compared to being prompted for it.)

Oh, that's disappointing. I was under the impression that it was possible to save these (Explorer has this option). I guess this is now a feature request then! :slight_smile:

I've seen an option about saving 'quick connect' passwords, but I guess that's something different?

As a workaround I put the username & password (, as you suggested, into the 'network location' address and it achieves the result I'm after, however, this is arguably a security issue as the password is now stored in plain text in the network location entry.

Yeah, that just tells Opus to remember the password typed into the quick-connect dialog, so that it can be recalled if you use the same dialog again.

Why not just use the address book entry? You can have the address book appear as a branch in the folder tree if you want.

Hmm, not quite what I'm after. The network location is perfect for what I want, with the exception of the aforementioned plain text password :slight_smile: