Amiga ADF/HDF Explorer

Yeah, I usually package my stuff I Open Source with pre-compiled binaries so those who are just "users" can run it right away without having to figure out how to compile code. Thanks for creating a binary though! :slightly_smiling_face:

I've had issues with this plugin crashing every time specific disks are accessed. My gut-feeling tells me the problem is handling of files named "AUX" and "" plus other illegal-on-Windows filenames ref:

Is the binary available then? I can't see it... am I being stupid?

Thanks for publishing your Visual C++ Solution. I'm not very good with VC++ so having your project as a starting point was very helpful. The opus VFS examples give you source code but no Solution you can just load and hit compile.

Appreciate it!

I was searching for such a solution and still can't find the release download. Where did you put it?

Still no binaries available.

Here's a compiled version of the current source from the github repository: (129.5 KB)

The 32-bit build needed some tweaking to compile, so I'm guessing the plugin's 32-bit version is untested by anyone. I've only done a quick test of the 64-bit version, which seems to work. I haven't checked the code or done anything beyond compile it and quickly see if it can open an ADF file in a VM. So use these builds at your own risk and uninstall them if you get instability. :slight_smile:

1 Like

Thank you for the binary!

Seems to work pretty good. I just have some .hdf files that cause Opus to crash. But for the most part it works. Of course I'm using it on DirOpus 11.19.

This is awesome - thanks Leo and segra.

Segra, if you are looking for bug report then I cannot get the viewer pane to work with anything except images and info files. Images seem to work fine, but no hex or text is displayed. Can anyone reproduce?

This is a true gem, thanks segra!
I've forked the project and will study it a bit, maybe send some pull requests towards your way.

1 Like

Hi all, I tried @Leo s binaries on 12.20 and could not get them to work (the 64bit DLL). ADF/HDF do not show up in preferences for VFS. So far tried only on Portable install, but is there anything else I should look out for?

Maybe you haven't copied the 64-bit DLL to the correct location.

Or you need to push the refresh icon at the top of the plugins list to get it to load the new DLL. (Or restart.)

No, that's not it. Even tried a reboot. Keep wondering if it is a portable thing.

It might need the Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019:

From your file dates, your portable install of Opus is also a year old, although that probably won't matter for this particular thing (since the DLL is about the same age).

Weird, I have the same issue with not showing up in prefs (12.20)
(Not portable version)

EDIT: Somehow it works now, despite rebooting and installing VC-Redist before

It shows up in my prefs, but doubleclicking an ADF file doesn't work. Dopus then just reopens the folder I was already looking at.

Maybe it's trying to open the ADF file in the lister, notices it's not working, and then refreshes the lister back to when I doubleclicked. I don't know.

This build works fine here, love it!

Thank you.
Windows 10 2004, Opus 12.21 Light x64

any update on this as for me it crashes every time

would love dopus team to show some love to amiga users and have this out the box if it was not for dopus 4 i would not be on dopus 12

We are happy to help plugin authors who have questions, but we have no interest in taking over this project or writing our own ADF plugin, sorry. Our time is already full with other work.