An error occured reading folder

Hi! When I try to open a CD directory, the following message appears :" an error occured reading folder, the parameter is incorrect (87)", after reboot everything is OK, but if I change the CD it may appear again. My OS - Win XP Pro+SP2+all hotfixs. Does anybody know how to resolve the problem? :frowning:

Does the problem only happen with Opus or with Explorer as well?

Is it a normal data CD? (i.e. Not an audio CD with evil copy protection that stops the drive from working if you have AutoRun enabled.)

No matter what kind of CD is in, the message appears even there is no CD in a drive! Explorer works OK, just if there is no CD it asks to insert one.

any solution yet?

besides error (87) i also get error code (1): incorrect function

CD and DVD drives give this output error. windows explorer loads the drives/folder of CD/DVD drives without problems.
(windows integration for xp/vista CD is checked/on in the prefs)

I don't think anyone else has mentioned the same issue since the original 2005 post was made. (Not from memory of the forum, anyway. Edit: Someone else reported something similar, though only about blank CDs, in 2006; see reply below.)

I'm not sure if it was reported to GPSoftware or not, but sending them a report is a good idea if you want them to look at it.

It may also help to know the make/model of CD/DVD drive(s) in use in case it's something specific to them.

The other thread you replied to was about blank CDs, while this thread is about all CDs. Which of the two is what you're seeing?

ok, no prob... i thought of opening a new thread first cause these 2 are very old ones.

i am just trying out the NeroOpus Toolbar or want to modify it but it makes not much sense if i cannot access/read the drives properly. (all commands/functions and access of drives/discs in nero work 100%)

if i am inserting a retail CD/DVD disc to load it works, but any R/RW discs or actions brings dopus in trouble.
my drives:

maybe i need a special windows service running that is dopus in need of to function properly with CD/DVD drives?

i got both errors:
error 1 on blank CD/DVDs
error 87 on written CD/DVDs

For blank CDs, Opus relies on the CD-writing system built into Windows (assuming it is working that Opus is configured to use it). I'm not sure what that depends on (system services etc.) but if it's working in Explorer then it should also work in Opus.

Getting an error for CDs which aren't blank is more strange (if it's just in Opus). Do you have any anti-virus or similar software which might be blocking Opus from accessing removable drives? Or anything like AnyDVD which modifies drive behaviour? (AnyDVD is great, but if there are problems it's worth ruling out that kind of thing in case it's a factor.) You could try using Process Monitor to see which operation on the drive is returning an Invalid Parameter error which might point us in the right direction.

Do you get the non-blank error 87 on both drives or only one? It's fairly difficult to search Google for but I did find some other threads which sound very similar and don't involve Opus, e.g. ... =1&t=15169

good ideas...
i closed anydvd and avast, but there is no change. still getting errors!

i inserted a blank DVD+RW disc in the LG drive. can't read it within dopus. this time i got a new error: 1005
"The Volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted."

Windows Explorer reads the disc without problems!

clonedvd gives the same error.

i think i have to look into the CD driver/filter system on my PC, anything is wrong there...

I'd concentrate on the problems with non-blank discs first.

Blank disks really don't have a filesystem on them so it's a legitimate error, although one which the Windows CD writing system should hide if it's being used. More components and things that can go wrong with blank discs, whereas non-blank discs should just work (and fixing them it might fix the blank discs as well).

ok, starting from the very basics now... i got a first successfull step further (but only tested it with CD - NOT DVD)

i was googling a bit around and made these things:

  1. deleted \system32\drivers\cdr4_xp.sys and \system32\drivers\cdralw2k.sys (some old easy cd-creator things? by sonic solutions?)
  2. disabled anydvd (from autostart)
  3. removed values of upper and lower CD filters [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}]
  4. reassigning/changing of the corresponding CD recorder drive = volume no. (\?\Volume{xxx...}) from my DVD drive no. [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CD Burning] and changing the number of drive types [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CD Burning\Drives\Volume{xxx...}] to 2 for the recording drive (LG DVD) and [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CD Burning\Drives\Volume{yyy...}] to 1 for the reading drive (Plextor CD)
    NOTE: it is only possible to have ONE recording drive - NOT two! ...uhh! i love windows :wink:
  5. ensuring that the CD recording tab of my choosen CD-RW drive (LG DVD) is checked and the one of my CD read only drive (Plextor CD) is UNchecked
  6. tested burning and erasing of my LG DVD drive with the windows built in CD burning and tried to read the full AND empty CD discs in explorer and dopus = it works! :smiley:

now i will go for DVD checks...

i have just read that windows can NOT write DVDs, so i changed all back to CD mode. "Do you want to record onto blank DVD disks using a recordable DVD drive? Windows XP can read and play back DVDs, but it can't record them."

Vista / Windows 7 can write DVDs, so it's just that nearly 10 year old OS you're using that can't :slight_smile:

ok, next step... cause the xp CD burning function was not really the point i think.

i have reenabled the autoplay/autonotification of the CD/DVD drives now:

  1. [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] NoDriveTypeAutoRun="91" (145)
  2. [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom] AutoRun="1"

now i see the correct icons and labels of the drives again if i change the discs. if turned off old icons/labels stay although you have a different medium inserted and browse different files.
this helps to identify better if any and what type/name of disc i have inside my drives.

unfortunately it doesn't change anything at the error code problem (1) and (87) - which i got also in windows explorer now! :frowning:
mainly it occurs if i erase a disc in nero and want to read it in explorer/dopus.

i mean autorun/autoinsertnotification of course - NOT autoplay

just a question: can you read/access blank DVDs with explorer/dopus?

i get always the error code (1), but blank CDs work... strange!

[quote="delatoy"]just a question: can you read/access blank DVDs with explorer/dopus?

i get always the error code (1), but blank CDs work... strange![/quote]

It should work in Windows Vista/7 but not in Windows XP, since XP's disc-writing support doesn't handle DVDs. (Since XP can't write to a DVD, what else would/could it do with a blank one than show an error?)