An error occurred generating thumbnails


After opening a picture directory, an error dialog appears.

No other exceptions after closing the dialog.

That's usually (although not always) due to a third party component crashing, when we ask it to generate a thumbnail.

If you send us the crash dumps we may be able to tell you more.

1 Like

Thanks Leo, I have sent the dump file.


It looks like that crash is in our code, and we've made a fix based on the information in the dumps.

If you can work out which JPEG file triggers the crash and send it to us, that would help us ensure we've fixed the issue. We think we have fixed it, but it would be good to be sure.

I opened the directory of \我的素材 (\My material) at that time, and I haven't opened the picture yet.

One of the JPG files in that folder is the trigger. It's happening when the EXIF data is read.

Can you work out which one?

An easy way is to copy half the files to a new folder, and the other half to another new folder. See which one still triggers the problem. Then split them in half again, until you're down to just one file.

I see,

This folder has 7,150 pictures and I will try to find it.

I verified the thumbnails of each picture and did not find that picture.

I restored the system and wanted to reinstall Opus and verify it again, But the website has been unable to download.

Yesterday's beta ( Directory Opus 12.18.2 (Beta) ) has the possible fix, so if you can download that and the problem no longer happens, it should be solved.

When the network was good, I downloaded this version and found no error. Then I deleted it and wanted to download the previous version again, but now both versions cannot be downloaded.