ANSI - UTF-8 - Unicode and failed imports

Like a number of others on the Forum, I have been having no success with importing saved Settings and Theme files (old ones AND ones that I just made). So, after a number of uninstalls and installs of various Dopus versions, and no luck, I decided to do a deeper investigation of the saved files. After extracting files from various ".dps" and ".dlt" (.zip files) files, I eventually discovered that Dopus was saving the internal ".dpf" and ".xml" files in UTF-8 format and the ".xml" files began with <?xml version="1.0" encoding="UTF-8"?>. There is no way that my UNICODE registry will accept these files in this format. If I change a ".dpf" file to a Registry file (.reg), and save it in UNICODE format, the file makes the changes without any problem. However, this is a pain in the butt.

Can someone on the Forum or from GPSoft explain how to solve this problem. I tried "clean" uninstalls and installs, but there is evidently something in the Registry which I am not deleting, or a problem with the program itself.



I'm a bit confused as to the actual problem you're encountering (what "others on these forums" are you referring to?) but the fact that Opus saves its XML files encoded as UTF-8 makes no difference whatsoever.

The files Opus generates are NOT .reg files - they are not designed to be loaded by regedit.

The only thing that should be reading these files is Opus itself, and Opus has no trouble at all with UTF-8 encoding (which, by the way, is exactly the same as plain ASCII unless you are using Unicode characters in the space above U+007F). ... ght=import ... ght=import ... ght=import

You evidently know a hell of lot more about the program than I do... So, tell me, what may be causing the problem?

Switching between ANSI and Unicode versions of Opus seemed to solve it for the person in the first thread. (Or rather caused it, then switching back solved it.) So that may get things going for you as well.

Could you or someone else with a prefs file that won't import please post the file in question so that GPSoft can take a look at it? Also say which version (ANSI or Unicode) exported it and which version is failing to import it. My guess is it'll be pretty easy to fix once it can be reproduced.

Another thing to note is you should be able to switch between ANSI and Unicode versions without doing a prefs export/import, so if you need to switch to the Unicode version, first import your prefs in the ANSI one (which should work if my assumptions are correct) and then install the Unicode version over the top (which will inherit the ANSI version's settings). If it's just the physical import code which has a problem somewhere then this bypasses the issue. I've switched between versions a few times by installing over the top as I needed to when testing plugins.

Here's one that I just made / exported, and won't import (UNICODE) ("Settings import failed") (21.5 KB)

Attempting to think of and try things that may relate to the problem being discussed, I just tried to switch from shared configuration files to individual user configuration files. No matter how many time I go through the change, when I reopen the program, the Preferences Box always shows "shared" - The program evidently won't make the change. Could this have some bearing on the issue?


It's possible. A few people have found that, for some reason, the permissions on their profile directory have been changed so that they can't create files in there. If that's the case then Opus won't be able to copy the configuration files into the profile directory and will revert back to using shared configuration.

NudelTest.dps imports fine for me - anyone else care to try it?

Thanks, jon. Now, at least I know that the data is getting exported correctly.

Imports fine for me too.