Artifacts in images set as wallpaper

When using the Opus command to set an image as my desktop wallpaper, the resulting wallpaper is full of compression artifacts. Does the image get converted before being set as the wallpaper? Is there a way to avoid this?

The default is for the wallpaper to be converted to a bitmap (.bmp) file which is a lossless compression, and so would not cause any artifacts. If you've changed the wallpaper to a JPEG file by editing the setwallpaper_file setting in Preferences / Miscellaneous / Advanced, then it is compressed. You can specify the JPEG quality by appending the quality value to the output filename.

it's still set to bmp. but there are artifacts. i guess it's time for more screenshots :slight_smile:

original image:

screenshot of the image set as my desktop wallpaper using Properties SETWALLPAPER. notice the artifacts, especially in the bottom right corner:

i should note that setting this same image as my wallpaper using my default image view XnView works just fine...

Do you get the same artifacting if you convert the PNG to a BMP using the Opus Image Conversion function?

no, it's nice and crisp. i'd attach it but it's nearly 8mb!

If you haven't changed the wallpaper file settings, Opus stores it in your My Documents folder by default - so have a look at the .BMP there and see if it has the artifacting. I'd be surprised if it does (since the function that saves it as a .BMP is the same as the one in the Image Conversion function), and this would indicate that it's something Windows itself is doing when it displays it as the wallpaper.

the bmp there looks fine.

i opened explorer and used the Windows function there to set the bmp as my wallpaper, and the artifacts appeared. so you're right, it's a windows thing.

and yet XnView applies the image just fine. dunno!

Same thing happens also if you tell Windows to use the original PNG as a wallpaper (i.e. without Opus being involved at all, not even converting the image into a BMP). I also tried re-saving the PNG as 24-bit (no alpha channel) but same results.

It does seem strange, like Windows is converting the image to JPEG for no reason.

Irfanview also has a "Set to Background" option that will show the wallpaper in it's original glory! :smiley:
Windows 7 converts BMP/TIFF/PNG to JPG for wallpaper:

Maybe try using the above mentioned configuration option to tell Opus to convert to JPG format, then you can specify the quality (presumably Windows is doing the conversion at a low quality).