Assign file ext to open with Opus instead of media player

You can assign it but it doesn't seem to work.

I think the simple audio player in Opus may check for the .mp3 file extension as even if I create a SWA filetype so the files successfully play in Windows Media Player (which will be using the same underlying systems as Opus for playback), the Opus audio player still doesn't like them.

There may be more to it than that, though. I recently discovered that MPEG and MP3 stopped playing inside Opus on one of my machines and, for some reason, just telling Windows Media Player to take over their associations fixed the problem. It's still fixed even after re-associating the files with a different media player so creating the association must have repaired something else in the registry which is needed for playback in Opus to work. (Maybe MIME types? I don't know and I can't check now as everything works...)

The weird thing there was that MPEG and MP3 files did still play in Windows Media Player and Media Player Classic.

...But it may just be a simple, hard-coded file extension check. Opus often looks at the contents of files, rather than their extensions, to work out their formats but the audio player in Opus is very basic so it wouldn't surprise me too much if it looked at extensions instead.