Bug: Closing a Lister from the Taskbar doesn't close


I've been using Directory Opus for years now, ever since Magellan on the Amiga :wink:.

Anyway, a bug has suddenly appeared over the last few months that is intermittent. When you right click on a lister on the taskbar icon, and select Close Window, it doesn't actually close. Doing this a few more times (seems to be random), it eventually closes. Closing the Lister other ways; the X button in the corner, or via the File menu, it always closes.

I'm not doing anything special to Directory Opus, using the default settings for everything, no custom toolbars, or strange lister layouts, and I'm on the latest version ( from the updater. I tried to fix it today, by reseting my preferences, unfortunately this made it a lot worse and the lister rarely closes through the right menu now. I'm at a lost of what it could be. My operating system is Windows 7 64-bit, and again. I don't have it customized or anything that isn't normal, and I'm not running autohotkey, windowblinds, or any program like them.

Hope someone can help!

Something like that will happen if you run Opus elevated (rather than running it normally and using the Admin Mode to elevate individual Opus windows as needed). Are you doing that?

A quick way to check is to see if you get a UAC prompt when you create a folder under C:\Program Files. If you don't get a prompt, Opus is probably elevated (or UAC is turned off).

Hmm, Doesn't seem to be.

I get a UAC prompt if I try and create a folder in Program Files.

Thanks, that can't be it then.

If you select Preferences / Launching Opus / Explorer Replacement / Don't replace Explorer, click OK and then reboot the machine, do you still see the problem?

Another thing to try: Un-pin and then re-pin the Opus taskbar icon, if it is pinned.

Ahaha! That worked (Don't replace explorer)

But setting it back to replace explorer,makes it closes intermittently again.

Re-pinning the icon was one of things I tried before posting.

Do you have anything else installed that might replace or intercept Windows Explorer, or anything like alternative shell tools or things which hook the desktop/taskbar or similar to modify their behaviour?

No, nothing strange. The only things I can think of are either;


I've exited both, and the problem still remains.

If it helps, I could PM you a screenshot of Process Explorer, of all the running all the processes I have.

If you have Spy++ you could try seeing exactly what window is being sent the WM_CLOSE message when you do that.

I have Spy++, and have it running. Would you give me a pointer of how to watch the events of the Lister? I couldn't figure it out.

  • From the menu, select Spy->Log Messages
  • Turn on the "All Windows in system" option on the Windows tab
  • On the Messages tab, click Clear All, and then locate WM_CLOSE in the list of messages and select it
  • Click OK

Okay, this is weird.

The act of Spy++ running and watching all of the windows, fixes the problem. Exit Spy and the problem comes back again.