Bug copying/moving files on Buffalo Cloudstation (solved)

Hello all,

I am encountering an incredibly glaring bug in DOpus. Maybe I'm doing something wrong, but I fail to see how.

Here goes. I try to copy or move files on a NAS drive (Buffalo Cloudstation 1 Tb) through the network.
For random files, DOpus says "there is not enough space on the destination drive", although there is. Can't be copied.
Worse, for other, it behaves as though it has copied the files, with progress bar and all, but nothing shows on the destination drive. Hence, if you move the files, they just... disappear. Removed from the source drive and never arriving on the NAS.

The WIndows File Explorer copies the same files just fine.

As I just shelled $240 for the 5 computer-license, I will admit I am a bit angry and mightily disappointed by such a highly regarded piece of software. (Before you say I should have tried before buying, I did try the software... on my laptop for weeks as I was on the road. Anyway such a bug is intolerable.)

Any advice, workarounds or corrections would be greatly appreciated.

Please check that you have the latest Buffalo software/firmware installed on the drive (and the computer if applicable), as we have seen problems in the past with NAS drives which turned out to be bugs in the NAS itself which were already fixed.

I just checked Buffalo site and the list of updates for a similar drive type (I'm not sure if it is the exact model) included this in the release notes for the most recent update:

- Fixes issue in P drive application under Windows XP SP3 which reported that no space was left in the disk when copying a file

That sounds similar, so it may fix at least one of the problems you are seeing. (They say Windows XP, but I suspect what they mean is Explorer on Windows XP, and anything which copies files in a similar way on any other OS.)

Most NAS drives are tested a lot with Explorer, so it would be surprising for bugs in them to show up there, but not well tested with other software which may copy the data in a slightly different way.

If updating the NAS software does not fix the problem, or only fixes one of the two problems, please generate a Process Monitor log recording what happens when the error or missed files occur so that we can diagnose what's happening:

[ul][li]Download Process Monitor from Microsoft.

[li]Set it so that only File System Activity is being logged:

[li]Clear the log (Ctrl+X, or the last icon in the 2nd group on its toolbar).

[li]Re-create the problem copying files to the NAS.

(You should see lots of lines in Process Monitor with Process Name "dopus.exe" and Paths relating to the source and destination of the copy.)

[li]Back in Process Monitor, use File > Save and use these settings when prompted:

[li]Zip up the PML file and send it to me via a private message. (To send a private message, click the PM icon, under my name on the right of this post.)

(You probably don't want to attach it to a public post, in case it has info you want to remain private. e.g. Computer names.)[/li][/ul]

It may also be worth trying other programs which can copy files, to see if they also recreate the problem, although it's only worth trying programs which have their own file-copy engines. e.g. TeraCopy is worth trying; on the other hand, some alternative file managers copy files by asking Explorer to do the work.

As a temporary workaround, it's possible to set up a button/hotkey in Opus which copies files via Explorer (details here).

Thanks for the procedure. I'm sending the log file via PM.
I have checked for the firmware and the NAS says it is up to date.
I have found the Explorer workaround in the meantime, I installed the corresponding buttons in my DOpus but it is a bit awkward. Will do for now, thanks.

Please double-check your firmware version, as the most recent release notes for your NAS include a fix for this exact issue by the sound of it:

The firmware can be downloaded here:


Note that it is separate and different to the Buffalo / Pogoplug software you install on your PC. The firmware is installed on the drive itself. It should say "Ver.1.13" if it's the latest.

[quote]How to confirm firmware version:

Select CS-X,CS-WX or CS-WV from NAS Navigator2 utility search screen.
The firmware version is displayed right and bottom corner in the status screen.
If the unit name shown CS--EM in the status screen, the CS-X,CS-WX or CS-WV becomes EM (Emergency) mode.[/quote]

Thanks, I tried that and it worked!
I want to apologize for what was such a simple issue at the end and for thinking DOpus was at fault. It seems the Buffalo auto-updater has an issue, as it kept saying the NAS was up to date, and I did not think to look beyond that.
You rock :slight_smile: