Button for Hide Filters in Folder Options

I have a sudden need to be able to hide display of images in a large directory. I've set Hide Filters under Folder Options OK. It works very nicely to be able to toggle the display with "Show everything". I'm wondering how I could enable this for any new tab I go to in the lister, without haveing to set up the hide filter again for each tab. I am very unskilled at creating buttons, though I do have 2 or 3 custom made ones. Would it be possible to have a button for controlling the "hide filters", and if so how would I build it?

I made a little progress myself, though not exactly what I asked for. In the Folder Options screen I did a "Save the current folder format:" and then in 'other' lister tabs I used the Folder Formats drop-down to Reset to "User default" format. This seems to turn on the hide filters settings I created in the original folder. I don't understand everything that's happening, in particular what all the possible settings in Folder Formats mean.

A Quickfilter might be all you need.


Set QUICKFILTER=~*.(jpg|jpeg)

Thanks! I tried setting up a button on the toolbar (Customize: dragged File Filter to the toolbar) and edited it to Function: Set QUICKFILTER=~*.(jpg|png). However, it doesn't seem to do anything. Is this anything like what one is supposed to do to make use of your suggestion? Sorry I'm so clueless about this!

Thanks Leo - I will read that.

I believe I now have a button on the toolbar which functions. However, using the suggestion by lxp of Set QUICKFILTER=~*.(jpg|jpeg) seems to restrict the display to just those image files. What I want is to hide those file types. I was hoping the tilde "~" symbol might mean negation, but it doesn't seem to. Unless of course I screwed something up. I want to hide all (or mostly all) image file types.

Try this:

Set QUICKFILTER=~(*.(jpg|jpeg))

(Edit: Removed stray ` character.)

Also note that it'll act as a toggle automatically, so you don't need a separate button to clear the filter.

Leo - I tried that (without the leading backquote, which lead to an error message). But it is hiding all files, not just those file types. I tried to be really careful in entering - tried copy and paste too. I'm on DO v12.21 x64 Pro.

Strange... works here with and without the additional brackets...

Using a filetype group works as well:

Set QUICKFILTER=~grp:Images

Did you set some other filters or filter flags?

I guess there must be some other filter somewhere, but I don't know what. In Folder Options I have tried reset to factory default format. Do you have a suggestion for how I might detect any other filtering going on?

Actually, it may be working now. I was playing with the drop down for the quick filter and tried selecting Images. Then went back and toggled things on and off again. Now my QuickFilter button seems to be working. I don't understand, and probably can't precisely repeat the steps involved, but I'll work with what I have for now anyway.
I may well come back again...
Thanks for your help!

You can use


to clear filters and filter flags.

Also, make sure the filter bar options are not set to regex:

1 Like

AHA! I did have regex checked. I've forgotten how, if I ever knew: Is there a quick way to enter a command like Set QUICKFILTERCLEAR somewhere, or do I have to create a button to implement that?

You can type > into the file display to open a command field.

If the filter bar is visible, there's also a clear button in that, next to the wildcard/regex field.

Many thanks. I think I need to take time to try some things out and experiment a bit more. Things are starting to make sense to me now, though there are still some mysteries.

1 Like