Cache thumbnails?

My Current Folder have 18827 Image file in jpg format. view = Thumbnail; 1st Time I Open that folder Take Times for loading it's OK, but after loading all files if I go 1 level UP for a while then get back in the Image folder it's takes Same Time for loading. Each and every time it takes Time. Is there any way to keep folders cash for reduce loading time ?

Thumbnail caching is configured under Preferences / File Display Modes / Thumbnails.

This is my Current Setting but Still that's not effect on loading time, what should I do?

Then it should be caching them already.

Are you sure it's the thumbnail generation that's the problem and not something else that's slow (like listing the folder, or the PC is just slow or low on memory)?

You could try turning off "load all thumbnails in a folder automatically" to reduce memory usage to just the thumbnails that have actually been displayed on screen, which might help if memory is the issue.

Doesn't look like it involved thumbnails. The file list hasn't shown up yet, and the thumbnails appear instantly once the files list appears.

If you send us some process snapshots, made while the delay is happening, we can probably see from those what's causing the delay.

How to capture the Process snapshots?

Edit: My mistake, the URL was broken, but it's fixed now.

Yes I did,

My mistake, the URL was broken in my post.

I had sent the file in provided email.
as well as I give a link here: (removed)

How many wildcard/regex labels do you have in your config? It looks like the delay is caused by calculating which labels match the files. That would not normally take very long, even for 18,000 files, but might if there are a very large number of labels (or if the CPU is slow etc. of course).


Assigned Labels:

Where to find the number of wildcard/regex

If you disable all the Wildcard Filters in your second screenshot, does the problem still happen?

after disable all the filters, Now It's load firster then before, there is no Problem. So what is the final fix for me? Disable all filters?

Try re-enabling a few at a time to work out if it's a particular filter that's really slow.

It could also simply be the number of filters. Combining ones that end up as the same label may speed things up, as well as removing any you don't really need. You can also configure filters to only affect particular folders instead of all folders, so you only slow things down in places that you actually need them.

1 Like