Can not input words with IME in filter bar

Only happends when you set filter bar with no hotkey and type without filter bar shows, then use a non-Latin IME(like CJK), the words you typed will shows in a small box with a green arrow on the top left of the screen, and if you type space or enter to send them to the screen, only the first character will shows in filter bar.
Windows 8/8.1 tested, chinese and japanese IME tested.

I'm not sure that we can change that since the characters (words) being input at the start will all go to the file display, and in that configuration any character sent to the file display will turn on the filter bar (if it isn't on already), then set that character as the filter (replacing any existing filter), and then give the filter focus so that it can accept further characters. Each character sent to the file display will overwrite the previous one, rather than be added to the filter; additional characters must be typed into the filter itself and not the file display.

If we changed how that behaved, it would break the normal behaviour where clicking on the file display and then starting to type a new filter replaces the old filter.