Cannot Drag Folders Out of a TAR

Per the title of this thread, shouldn't this be possible? Trying to drag a multiple-selected set of folders out of a TAR and into an empty folder on the desktop. Nothing happens.

V on Win7 Pro 64

It seems to work fine here, using a TAR created with Opus itself.

Are you moving or copying the directories?

Does it only fail if you use drag & drop or does it also fail if you select the dirs and click Copy Files?

Are any of the dirs (or the ones below them) empty? (There's a known issue with empty dirs that I'm fixing at the moment.)

If none of the above apply, try opening the same .tar file using 7-Zip to see if it has the same problem.

Hi Leo,

Well, this is a pretty big zip that was generated by the "archive gateway" (vDeck/apache) of my entire, multi-domain web hosting account. WinZip balks at the file. Opus reads the file just fine. As to your other questions:

I've tried just left-click-dragging a folder out onto the desktop, and since both are on C:, I guess that usually qualifies as a move, although I don't expect zip/tar operations to behave like same-drive operations, so ostensibly, I think it should be handled like a copy.

I have right-click-drag, and choose copy to the desktop. Still no joy.

Are there empty folders? Not sure. Not all that likely.

Actually, I seem to be noticing things not working quite right for zips and tars. I mistakenly used TAR in the title of this thread. But whether tar or zip, I believe I'm having problems either way. I've tried smaller archive files and not gotten much farther.

I just tried dragging a small folder to the desktop (fully contained in Opus) and it worked. So I tried another from a different zip and got an error dialog saying:
"An error occurred copying 'fbbanner.png': Access is denied. (5)"

I've been getting that error 5 thing when copying from one ftp site to another, too.

Just kind of a frustrating morning fighting to get files from one place to another. ftp, zip, and tar all giving me fits.

If WinZip is also having problems with the same archive then maybe the archive isn't valid and the problem is how the archive is being created?

Does the archive work with anything?

Please also try using the Copy Files button on the toolbar, not using drag & drop at all.

You can ignore the empty folder angle if we are talking about Zip and not Tar. The issue I was talking about does not affect Zip files. (Zip and Tar are handled by completely different components in Opus so which we're talking about is an important detail.)

Quick followup on this issue.

The zips are valid, and other zip utilities can apparently deal with them. The zip utility available on an Apache server, for instance (whatever it is or however it's actually called I'm not sure; I was using XCloner, to move a WordPress site from one host to another and it calls whatever unzip module is common on an Apache server,) was able to successfully read these zips. Now that I think of it, the zip was created my an Apache service, too, so maybe the odd behavior of the files is attributable to that zip module.

Anyway, I have started using the copy and move buttons more. Can't say I've ever had errors doing it that way, but it does seem unnatural. Windows is supposed to be all about drag and drop, so it's kind of curious that using a button to effectively do the same operation would work better than a drag-n-drop.

Overall, and if I may be so bold, it seems like these operations (zips, tars, and drag-n-drop from them) might be worth additional testing and scrutiny. It may just lead to some nice improvements. Regardless of these issues, nothing could dissuade me from using Opus. The price initially raised and eyebrow, but I can't think of any better utility or one used as heavily as I use Opus, and therefore it passes the bang for the buck test brilliantly. ClipMate is the only other totally indispensable utility I can think of, and perhaps used at least as much.

Out of interest, how big is the zip file?

I think it was the big one I've got here which clocks in at 1.09G