GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Cannot open Win10 Modern App Shortcut within Lister


#1

Cannot open Win10 Modern App Shortcut within Lister, but can open in Desktop, Taskbar, and Win Explorer

This does not seem to be a Lister bug but rather a Win10 limitation.

Are there any workarounds for this?

Thanks


#2

Which app? How was the shortcut made?


#3

Hi, sorry for the delay. Attached is a screenshot (1 picture = 1000 words)

Same Desktop icons, in Windows Explorer side by side with Directory Opus 12 latest version.

Note that Windows Apps (modern) for Messenger (facebook) , WhatsApp and OneNote (Win10 version, not standalone OneNote 2016 which notice works on both), and modern system Power icon (for Power off options), have normal icons and launch ok from Desktop, Windows Explorere and a few other Win10 locations (Startup, Taskbar, All Programs launch)

but have a white icon in Directory Opus lister on the right.

When I tried to launch the white icon Messenger app from Directory Opus, a get the error panel you see, Element not found.

I am thinking maybe Win10 is limiting access to its apps to its Explorer interface?

As you may know, Win10 does not allow even administrators to read the Apps directory

C:\Program Files\WindowsApps

Pls advise, thanks


#4

How did you make that shortcut?


#5

I did not create the shortcuts for Messenger, Whatsapp, and OneNote, I installed these programs from Win10 Store (OneNote and Skype are default in Win10), and the installation created the shortcuts automatically in Desktop.

As for the Power App (Win10 Power Settings) which is white icon in Directory Opus, I created that shortcut from modern Win10 Windows Settings > Power, having said that, I cannot recreate how I created that shortcut.

Thanks


#6

I just installed (Facebook) Messenger (non-beta) from the MS Store but it didn't auto-create an icon for me on the desktop.

Dragging it from the start menu to the desktop created a shortcut, but it worked fine in Opus.

If you turn on the Description column, does it tell you what the shortcut points to?

I get Target: Facebook.<random-numbers>_<random-lettersandnumbers>!App


#7

something similar but always with Target shell in front:


#8

Try deleting that shortcut, then drag the item out of the start menu to a folder (or the desktop). Does it work then?


#9

From the Start menu, Apps directory where all of these icons are shown (Win10 modern apps), I cannot drag any of them with my mouse cursor. I right-click with the mouse to create a shortcut, get a notice that a shotcut cannot be created here,should it be put on Desktop, I clck YES and a full color icon appears on Desktop. I then drag the icon (Messenger in this case, tried with Win10 OneNote too) to Directory Opus folder D:\ where I have other downloaded programs that launch fine, and there a Messenger shortcut with white icon appears. When I try to launch it, I get the same Element not found panel.

I have new Dell XPS desktop, bought in December, with new Win10 and all updates downloaded


#10

I created shortcuts for other apps, note they are all white icons in Directory Opus. They launch fine from Desktop.


#11

I did a uninstall of Directory Opus with Revo uninstaller, reboot and clean install version 12.11

Still shows Windows Apps icons as white icons.

Maybe I have to do a Windows 10 reinstall but I would like to avoid that.


#12

That's very different to how my Start menu behaves. Do you mean the Start menu itself or something inside of it? I don't have an "apps" directory within the Start menu here, unless you mean the main menu itself? (But the main menu lets me drag out shortcuts, and doesn't have a shortcut option in the right-click menu.)

I am using Windows 10 1809, for what it's worth.


#13

Neither do I in the standard Start menu, but I have Classic Shell installed and the Start menu as presented by it does have an Apps entry. I have no idea whether or not that's relevant here.

image