Cannot save preferences

Thanks. I just tried what you suggested. I was able to create a new text file there, then open it, modify it, close and reopen it again with the changes intact. So that doesn't seem to be it.

Please make a process monitor log and we'll see if it indicates why the config file can't be updated from Opus:

In this case, to ensure the right things get logged:

  • Start logging as per the linked post.
  • Toggle the Apply checkbox in the metadata panel.
  • Wait 45 seconds.
  • Save the log as per the linked post.

The 45 second wait is because the config change is not saved immediately, in case other changes are made soon after it and can be batched together.

It might also be interesting to check what the Modified date on this file is:

C:\Users\<username>\AppData\Roaming\GPSoftware\Directory Opus\ConfigFiles\prefs.oxc

That would tell you the last time Opus was able to update its main config file. The date/time might help if it coincides with when something was updated/installed.

If file permissions aren't the issue, sometimes antivirus is. We've also heard of cases where the Windows Search Indexer gets stuck in an endless loop on XML files, which could be what's happening.

Thanks. To address the second part first - that prefs.oxc file has not been updated since 31st Decemberm late in the evening. So it seems locked.

Secondly, I now have a Logfile.PML. Is that the format to have saved it in? However, not crazy about posting it publicly. Is there someone I could send it to?

In any case, the locked prefs file suggests another solution, perhaps.

PML is the right format. Please zip it and send it to the address in the instructions I linked above.

I just noticed that the logfile is 500mb for only a minute or so's activity. No amount of compression is going to make it mailable. How can I make a smaller logfile without applying filters?

Slow down when reading the instructions Leo linked :wink:

Zip up the log. It will be quite large if not compressed, but much smaller when added to a zip file.

1 Like

Whoops, sorry. Okay, have mailed a smaller log to Leo.

Just to let you know that I finally did the obvious - uninstalled and reinstalled DOpus, and it fixed the problem. However I would still be interested to know what the problem was, should it come again.

I also note that as far as I can tell DOpus removed locally saved backups I had made of my preferences prior to uninstallation, which is pretty counter-intuitive.

Uninstalling wipes your config folder but would not wipe config backups unless they were stored in the config folder.

Just to say that for some reason, which I cannot determine, DOpus will not save prefs again. At least this time the prefs that it won't override are better ones than before, but this really is a pain in the neck.

The issue is caused by something external to Opus locking the files so they cannot be replaced.

We aren't sure what yet, but so far one person has indicated it may be thr OS itself or something low level like antivirus.

There is more information here, as well as some tests that can be run to see if the locking process is the same on your system:

That post and the two after it.

It's probably best to continue in that thread, so the information stays in one place.

Please try the fix in this beta version, and let us know if it works for you:

n.b. For the fix to work, you must reboot if requested to at the end of the install.

Okay. When installed, DOpus opens a localhost page, by the way. Obviously it doesn't work!

It's supposed to do that the first time a new version is installed, to show you the new release notes. (You can turn it off under Preferences / Miscellaneous / Advanced [Behavior]: show_release_history.)

Do you still have problems saving Preferences or is it working now?

Reminder: You must reboot after installing the new version for the fix to work.

(Edit: In 12.13 and later versions, the setting is called display_release_history and is off by default.)

Right, I'm just saying that the page that opens doesn't exist, and presumes that a localhost server is running ( I've just installed it, so I'll have to see if the problem is fixed - finger crossed.

Opus runs the help server on localhost itself. If it's not working for you then possibly your AV/firewall is blocking it.

Having the beta info page as an unindexed page on your website (or a local page in a help file folder in the installation) might be a better idea. Running a localhost server seems like massive overkill for this purpose. I only have the usual adblocking plugins, and as I mentioned in another post, I have zero firewalls or AV running anywhere in the system.

Browsers won't run Javascript from local folders, and having the help only online means you can't access it without an internet connection (plus makes it a lot slower in general).

You have the option of using CHM files instead of the localhost web server.

Can we please get back on topic: Are you able to make configuration changes OK now that the update is installed?

Yes. However, I was able to also for a while after re-installing the non-beta latest DOpus release, so I'll get back to you if it changes in the next week.