GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Cannot view Microsoft Word .doc files in viewer

When I single click on a .doc file,
(1) it show it in hex/binary view in the viewer pane (appears to be set to "view as hex" by default)
(2) if I right-click in the viewer pane, and unselect "view as hex checkbox, then it still does not display properly. Instead it shows a bunch of "squares
" at the beginning, then the text in the document appears as regular text.

The viewer is using the ActiveX viewer (as it should be, according to my understanding). But when I explicitly select "use ActiveX viewer", it returns to hex view.

I also tried viewing using the "Multiview" viewer plugin, to no avail.

The supposed ability to preview files from within the lister, including especially MS Office files (such as I was able to do years ago with PowerDesk and OutsideIN), was one of the main reason i bought a Dopus 5-user license. I expected this to work "out of the box."

I have not done any particular configuration of the Dopus viewer, so why is this not working as advertised?

Which Office software do you have installed on the machine?

The ActiveX viewer allows you to use MS Office, Open Office or the free MS Office viewers to view Office files within the Opus viewer panel, depending on which you have installed.

[quote="leo"]Which Office software do you have installed on the machine?

The ActiveX viewer allows you to use MS Office, Open Office or the free MS Office viewers to view Office files within the Opus viewer panel, depending on which you have installed.[/quote]

I have Office 2007 Pro installed.

So why is the viewer panel not working???

If you're using Windows Vista or Windows 7, are you able to view Word documents within Explorer's viewer panel?

If you're using an earlier version of Windows and have Outlook installed, see if you can email yourself a .doc attachment and then, when you receive the email, view the attachment within Outlook itself by single-clicking on it.

With Office 2007, Opus should be using the preview handlers that are installed with Office, the same as Outlook and (in Vista/Win7) Explorer use. It sounds like the preview handlers are not working for some reason.

Check that the Opus ActiveX + Preview + Office + Web plugin is enabled (Settings -> Preferences -> Plugins -> Viewers) and then select it and click Configure. You should see something like this, with the MS Office preview handlers near the top:

Check that the MS Office Word preview handler is listed near the top, and enabled, with the appropriate file extensions (.doc, .docx, etc.) assigned to them.