GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Can't double-click .exe files


#1

After a recent update I now notice that all my File Types are trashed. DO does not even recognise a .exe file. It asked what app to use regardless of the file type.

DO 12 Pro build 6288

Any ideas would be appreciated.

Would be nice to be able to reset to Default


#2

Just a follow up....

I have today updated to Build 6369 and it is still trashed.


#3

Does double clicking the same files in File Explorer still work?


#4

Yes. Windows File Explorer is fine


#5

In Opus, please open Settings > File Types, then select File > Diagnostic at the top left, and attach the result(s) for the problem extension(s).


#6

Opus_FTD_File_exe.zip (33.1 KB)

Here it is.


#7

This looks like the problem:

64 HKCU\Software\Classes\.exe\
64 HKCU\Software\Classes\.exe\OpenWithList\
64 HKCU\Software\Classes\.exe\OpenWithList\Elmedia Player (Mac).exe\
64 HKCU\Software\Classes\.exe\OpenWithList\Elmedia Player (Mac).exe: "" is REG_SZ: "Elmedia Player (Mac).exe"

Open RegEdit.exe then find this branch and delete it:

HKEY_CURRENT_USER\Software\Classes\.exe

(Make sure it is the right branch. Do not delete the similar branch that is under HKEY_LOCAL_MACHINE.)


#8

Awesome Leo.

That fixed it.

Thankyou for your prompt and professional support.


#9

Well.... I thought it was fixed.

Today.... back to same old problems.

Will not recognise any file type.... exe, bat, shortcut.

Totally unstalled Directory Opus and re-installed.

Same problem.

This is only since updating to V12.

Will uninstall and try going back to V11


#10

The problem above was caused by something adding itself to the .exe Open With list, which nothing should do. It can cause problems system-wide. And it makes little sense for a media player to associated itself with the .exe filetype.

(It's possible Microsoft added some protections within Explorer itself to prevent this. In the past, it could make it almost impossible to launch any exe even via the Start Menu. I ran into it myself once.)

I doubt that going back to 11 will help, since the issue is something outside of Opus making incorrect changes to the .exe filetype, but let us know if you try that and find it does help; if so we can investigate why Opus 12 would be more sensitive to this than 11. The update to 12 would not have caused the registry change, either way; that is pure coincidence.

But you can probably also fix the problem by doing the same fix as before, deleting the registry entries above. If those entries keep being recreated by something, it should be taken up with the tool that is creating them.


#11

I had the same problem and figured out that the parallels option to share Mac programs with Windows created this effect. So I disabled it and then the subfolder in the .exe path in the above mentioned registry path has not been created anymore. It is necessary to delete the subfolder manually (I guess).