GP SoftwareTwitter
Opus FAQsManualCommandsObjects

"Can't find device" while syncing

I got a Dell computer running W10 a year or so ago. For some reason, D Opus finds it difficult to sync files on it. It is fine with an older Dell also running W10 that I use at home. As far as I am aware I do exactly the same things on both machines, but the newer machine regularly gets stuck and says that it can't find the device (an external hard drive) it is syncing to. If I keep clicking on "try again" it usually works, but this is time-consuming and frustrating. Any advice about what to do?

(I've moved this into a new thread, since it didn't seem related to the very old thread it was added to.)

If you get "can't find device" errors while copying data to a USB drive, it probably means there is something wrong with the drive or its USB controller.

Some USB drives have issues with certain buffer sizes, for example, although they really shouldn't. Some may also have issues when copying a lot of data at once, perhaps.

The error is coming from the drive/OS and not something Opus is doing. But you may be able to make the drive happy by changing certain settings.

Trying a different USB port or USB cable is another thing that may help. Also make sure you have installed the motherboard chipset/USB drivers for the machine (usually from Dell's website), as the generic ones may not work properly.

Have you tried copying large amounts of data to the drive using File Explorer? You may find the same errors happen there.

Which version of Opus are you using? The settings that are worth trying vary depending on the version.

Many thanks Leo. I will follow up your suggestions. This is the version of Opus I am using:

Directory Opus Pro 12.10 Build 6853 x64
OS 10.0 (B:18362 P:2 T:1) SP 0.0

Probably the file sizes are part of the problem on this machine. What is irritating is that I use the same version on an older Dell machine (still with W10) at home and very rarely have the problem. Regards, Mike

Any reason you're using a year old version?

No reason other than ignorance/laziness/indifference - the usual stuff. I don't think that another version would solve the problem, but your advice about settings could. Regards, MS

Please update to the latest version as it can waste our time and yours to troubleshoot things on older versions.

Please also link one of your two forum accounts.

OK Leo. I have installed the latest version. The syncing process was still disrupted and erratic. I'd now be grateful for your suggestions. Regards, MS

Have you tried everything above?

I can't see anything above, Leo. What are you referring to?

Where (in the name of God) is this count of new replies. Nothing that I can see refers to my question. Are you simply pointing me to a list of FAQs?

This was from my message above:

  • Trying a different USB port or USB cable is another thing that may help.

  • Also make sure you have installed the motherboard chipset/USB drivers for the machine (usually from Dell's website), as the generic ones may not work properly.

Another thing to try:

  • Set Preferences / Miscellaneous / Advanced [Filesystem]: copy_buffer_size to 64 KB (this will slow down normal file copies, but can fix things for some bad USB devices that fail with larger buffer sizes).

Please also link your account, or one of them at least. (I am assuming ms138 and sonenscher are the same person; apologies if I'm confused here.)

Yes. I am ms138 and Michael Sonenscher. Your user interfaces are too cluttered and too hard to make sense of for me to see where or how to establish a link, or to do much else. I will try to do what you recommend with setting the preferences. Regards Michael Sonenscher

You just need to click the link I gave you and paste your registration code into the box where there is an example registration code. It's very simple.

I have now made the link. No need to reply because the syncing problem centres on my Dell laptop at work and I will not be using that computer until my Tuesday. I will also try to find the right drivers from Dell for the USB ports and motherboard. MS

1 Like

I have a recurrent problem with Dopus on my Dell Inspiron using W10, which is that Dopus can't find my external hard drive to sync files from the computer to the external hard drive. Why? What can I do? This never happens with syncing the same external hard drive to my computer at home (also a Dell, but an older laptop whose name I can't remember offhand)

Can you see the drive under This PC (aka My Computer)?

Does it appear as a normal drive there, when looking in Opus and File Explorer?

Yes. I see it, but then the device drops off and comes back at high speed. Very often. M

Does it do that in both programs or online one of them?

How much have you tried to do with the drive using File Explorer on the same computer that's having problems? Is it able to copy a large amount of data to and from the drive, i.e. not just see it but use it in an operation that takes a minute or more?

I use Dopus not File Explorer to access the drives. It is never possible to copy a large amount of data easily to and from the drive using Dopus. Why?

I'm asking if Explorer has the same problem.

If it does then the problem is not with Opus but the hardware or drivers for the drive or USB, or a loose cable or something, but not Opus. If the hardware isn't working properly, and the drive is constant appearing and disappearing, then it won't matter which program you use to copy the data.

1 Like